FS: a/d/s Ph15 amplifier - 50% working - $50 - diyAudio
Go Back   Home > Forums > Commercial Sector > Swap Meet

Swap Meet Sell your stuff here, who knows, some other fanatic might be interested!

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th September 2007, 02:19 AM   #1
owdi is offline owdi  United States
diyAudio Member
 
owdi's Avatar
 
Join Date: Sep 2003
Location: Bellevue, WA
Default FS: a/d/s Ph15 amplifier - 50% working - $50

This is a classic 6 channel a/d/s car amplifier, but only channels 1,2 and 4 work. I don't know why the other 3 channels do not work. I have taken off the bottom plate of the amplifier, which exposed most of the pcb, but did not find any dark spots where something burned. I have no idea how to fix it, so it's up for sale.

I can provide detailed pictures of it's guts, upon request. Click here to see the guts of the PQ20, which is the very similar 4 channel version

a/d/s PH15 amplifier - $50
Continuous power output (FTC rated, 20Hz to 20kHz, < .05% THD)
6 x 50 watts (4 ohms)
6 x 55 watts (2 ohms)
3 x 100 watts brdiged (4 ohms)

More detailed specifications can be found in the PH15 owners manual. Please note that this is only a power amp, it does not have a built in crossover. It does not have RCA inputs, but instead uses a 8-pin din cable, which I also do not have. Pin out for the din is in the owners manual.

Some pics

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

If you need a crossover, I have the following two units available for $30 each.

AudioControl 2xs
4 channel 18db/octave crossover with 18db/octave rumble filter.
Crossover chips are 90hz and 33hz.
Link to owners manual

Sony XEC-1000 system crossover
10 channels! 12db/octave on mids and tweeters, 18db/octave for the subwoofer
It has tons of features, Read the manual to learn about it.

Some more pics

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.


Terms: Acceptable method of payment is paypal, or cash if you live in the Seattle area. Prices do not include shipping from 98005 to you. I will ship international, but only if you are willing to accept this stuff AS IS.

Dan
  Reply With Quote
Old 28th September 2007, 02:32 AM   #2
diyAudio Member
 
Join Date: Jun 2007
Thumbs up E-mail me

I am interested in the lot of amp and xovers you have for sale.
Can you PM or e-mail me as you don't have e-mail enabled.
Thanks,
Donovan
  Reply With Quote
Old 28th September 2007, 05:06 AM   #3
diyAudio Member
 
HIPCHECK's Avatar
 
Join Date: Jun 2004
Location: ARKANSAS
DANG DONOVAN!!!!

beat me to the crossovers I bet!!!

Ill take the sony If not already spoke for!
  Reply With Quote
Old 28th September 2007, 02:02 PM   #4
owdi is offline owdi  United States
diyAudio Member
 
owdi's Avatar
 
Join Date: Sep 2003
Location: Bellevue, WA
My email is danspublic AT gmail DOT com

Dan
  Reply With Quote
Old 28th September 2007, 04:24 PM   #5
owdi is offline owdi  United States
diyAudio Member
 
owdi's Avatar
 
Join Date: Sep 2003
Location: Bellevue, WA
As promised, the guts. I believe the dark areas on the PSU PCB are just flax.

Link to 2000x1500 pics

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Dan
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HPPA Amplifier not working flacer Solid State 14 30th June 2009 02:36 PM
**** amplifier for party is not working! Destroyer OS. Solid State 3 31st October 2006 08:26 PM
Car amp repair: Overheated my a/d/s PH15... Tremelune Solid State 0 31st May 2005 04:57 AM
no working amplifier Diogo Solid State 31 31st October 2002 05:58 AM


New To Site? Need Help?

All times are GMT. The time now is 09:55 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2