New Tang Band is BUSTED! - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd May 2006, 12:48 AM   #1
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Default New Tang Band is BUSTED!

Dangit my new Tang Band W8-740C is defective. It works but one side of the spider isnt glued to the Voice Coil and it makes noise. GGGRRRRRR


Serial Number # 365 Might want to check yours if you have S# close to mine.


Zc
  Reply With Quote
Old 3rd May 2006, 09:27 PM   #2
Speakerholic
diyAudio Moderator
 
Cal Weldon's Avatar
 
Join Date: Jan 2004
Location: Near Vancouver
Thanks for the heads up. No problem with mine but I did have something I thought was wrong. While testing the woofer and passive set-up, I neglected to pin the wires out of the way and it actually came in contact with the back of the PR causing a disturbing little buzz. So after pulling the woofer to find nothing wrong, decided to get my face right in there and found out what it was. What a relief. Wires up out of the way and voila, no problemo. Sorry to hear of your misfortune.
__________________
Next stop: Margaritaville
Some of Cal's stuff | Cal Weldon Consulting
  Reply With Quote
Old 4th May 2006, 01:39 AM   #3
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
I have to thank Parts Express for handling my problem with absolute diplomacy and professionalizm!

I called today and explain i have had the sub for about a week and the problem. I asked for an advance replacment to help speed the proccess up. The gentleman that handled my call explained that they normally dont do that unless i was a dealer but asked me to hold while he checked on it. he came back and said they would make an exception and ship me not only an advanced replacement, but also a return shipping tag so i didnt have to pay for return shipping for the defective unit! A+++ service!

I am really digging P.E. these guys rock!


Zc
  Reply With Quote
Old 4th May 2006, 02:38 AM   #4
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Quote:
Originally posted by Zero Cool
I have to thank Parts Express for handling my problem with absolute diplomacy and professionalizm!

I called today and explain i have had the sub for about a week and the problem. I asked for an advance replacment to help speed the proccess up. The gentleman that handled my call explained that they normally dont do that unless i was a dealer but asked me to hold while he checked on it. he came back and said they would make an exception and ship me not only an advanced replacement, but also a return shipping tag so i didnt have to pay for return shipping for the defective unit! A+++ service!

I am really digging P.E. these guys rock!


Zc

PE does rock i got my davis drivers from them. Good team good prices..
  Reply With Quote
Old 4th May 2006, 08:28 PM   #5
diyAudio Member
 
Join Date: Oct 2004
Location: t-dot, canada
Send a message via MSN to xstephanx
another shameless plug for pe,

great guys with GREAT service...my spider experience with adire was somewhat different. they did not want me to attempt a repair myself, so i said ill just return it and buy a different driver, at which point whoever i was dealing with decided that it was OK for me to go ahead with the self repair. IIRC they said that the repair coudl very easiy take more than a month.

although adire do make fantastic drivers, i geuss i just got a lemon.
__________________
CREEEAAAAAMMMMM CHEEEEEESSSSSSEEEEEEE!!!!!
EEEEESSSSEEEEEEHC MMMMMAAAAAEEEERRCCC!!!!
  Reply With Quote
Old 6th May 2006, 06:12 PM   #6
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Well P.E. got my advanced replacement driver out to me in 3 days! I carefully inspected this one. and BTW the Serial Number of this driver is #2!!! could i really have gotten the second driver from the run??

Anway, the glue looks very good and evenon the new driver. the defective one, most of the glue was on the spider and not the V.C.

I set up a test rig on the bench last night and ran the new driver with a signal generator and varied the signal from about 1hz through 200 hz at various power levels and DANG, this S.O.B. MOVES SOME SERIOUS AIR! my whole bench was jumping, shook the h*ll out of everything hahahahha!

So i got it installed in the car and it sounds great! I am using a Alpine 3548 amplifier bridged mono @ 160 watts and it is just enough to keep up with the stock BMW amplifier and Nak head unit. I wasnt after the big booming bass. just wanted to get some low end in the car and the stock 5.25" woofers on all 4 corners just didnt cut it.

I modified the stock amp and added some high pass filters on the inputs to roll the very very bottom off going into the amp. and i use the Nak's sub outs to drive the sub amp.

My only complaint is that the Loudness tracking isnt the greatest. at very low levels there is too much bass and at the max there inst enough. But oh well.


Zc
  Reply With Quote
Old 8th May 2006, 05:15 PM   #7
Speakerholic
diyAudio Moderator
 
Cal Weldon's Avatar
 
Join Date: Jan 2004
Location: Near Vancouver
Glad to hear you are happy with it. Makes you wonder why they don't wrap that thing in a cast basket and sell it for double.
__________________
Next stop: Margaritaville
Some of Cal's stuff | Cal Weldon Consulting
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tang Band W3-593SF vs. Tang Band W3-926SD Zaputh Full Range 17 6th June 2009 12:37 AM
Tang Band MTM ? wrenchone Multi-Way 11 21st November 2007 07:39 PM
8 x 12 Tang Band troystg Subwoofers 3 2nd February 2007 04:37 AM
Tang-band 2-way (W3+W8) haffe Multi-Way 10 1st February 2007 12:11 AM
Tang Band 8" sub Qts Dave Jones Subwoofers 2 3rd June 2004 12:53 AM


New To Site? Need Help?

All times are GMT. The time now is 05:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2