JBL PB12 dead? - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th May 2005, 07:42 AM   #1
diyAudio Member
 
Join Date: May 2005
Location: MN
Default JBL PB12 dead?

Ok, So I have a jbl PB12 that when I turn it on all is does is hummmmm quite loud. It is not connected to anything but power. I am pretty new to the audio/electronics world (I know computers) so I am not sure where to look. What should I be looking for? Can anyone please help me. Thank you.
  Reply With Quote
Old 24th May 2005, 07:48 AM   #2
simon5 is offline simon5  Canada
diyAudio Member
 
Join Date: Nov 2004
Location: Québec, Québec
I saw on the web that the problem is caused by a blowed up capacitor. It seems it's not a very reliable unit.

The best thing to do would be to swap the amplifier with a Rythmic Audio amplifier I guess.
__________________
DIYaudio for President !
  Reply With Quote
Old 25th May 2005, 07:24 AM   #3
diyAudio Member
 
Join Date: May 2005
Location: MN
any other suggestions?
  Reply With Quote
Old 25th May 2005, 07:35 AM   #4
simon5 is offline simon5  Canada
diyAudio Member
 
Join Date: Nov 2004
Location: Québec, Québec
Replacing the faulty capacitor.
__________________
DIYaudio for President !
  Reply With Quote
Old 25th May 2005, 02:11 PM   #5
theNoid is offline theNoid  United States
diyAudio Member
 
Join Date: Dec 2004
Location: Rock River, WY
Send a message via Yahoo to theNoid
Default Re: JBL PB12 dead?

Quote:
Originally posted by turkish621
Ok, So I have a jbl PB12 that when I turn it on all is does is hummmmm quite loud. It is not connected to anything but power. I am pretty new to the audio/electronics world (I know computers) so I am not sure where to look. What should I be looking for? Can anyone please help me. Thank you.
Ok, we need some info here.

1. Is this subwoofer new to you?
1a. If not new to you, has it worked fine in the past?
2. How loud is the hum?
3. Have you tried running a signal to the amp to see what happens?

Noidster
__________________
"Mmmmm......Beeeer"
  Reply With Quote
Old 25th May 2005, 02:20 PM   #6
diyAudio Member
 
Frank Berry's Avatar
 
Join Date: Sep 2003
Location: Midland, Michigan
This is a known problem with the subwoofer. Do a search and you'll find a rather lengthy thread which covers the problem in great detail.
__________________
Frank
  Reply With Quote
Old 25th May 2005, 02:57 PM   #7
diyAudio Member
 
Join Date: May 2005
Location: MN
Well I took the amp off of the back and all the capacitors look ok to me. Do you know which one it is, or how to tell which one is bad?
  Reply With Quote
Old 25th May 2005, 03:18 PM   #8
DcibeL is offline DcibeL  Canada
diyAudio Member
 
DcibeL's Avatar
 
Join Date: May 2003
Location: Saskatchewan
Quote:
Originally posted by Frank Berry
Do a search and you'll find a rather lengthy thread which covers the problem in great detail.
__________________
The power of Science compels you!
  Reply With Quote
Old 26th May 2005, 03:01 AM   #9
diyAudio Member
 
Join Date: May 2005
Location: MN
Do you know which tread? I searched and am having problems.
  Reply With Quote
Old 26th May 2005, 03:32 AM   #10
Kenshin is offline Kenshin  China
diyAudio Member
 
Kenshin's Avatar
 
Join Date: Jan 2005
Location: China
Class D forum
Quote:
Originally posted by Frank Berry
This is a known problem with the subwoofer. Do a search and you'll find a rather lengthy thread which covers the problem in great detail.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JBL PB12 subwoofer, Class D amp, dead. pat allen Class D 344 26th January 2014 07:39 PM
JBL PB12 replacement amp Tee-Bruce Subwoofers 1 18th June 2007 02:59 AM
JBL PB12 Amp Failure Galen Multi-Way 3 28th November 2001 09:01 PM


New To Site? Need Help?

All times are GMT. The time now is 11:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2