BASH 300S Blowing Fuses - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th February 2012, 09:32 PM   #1
cheryl is offline cheryl  United States
diyAudio Member
 
Join Date: Jul 2010
Default BASH 300S Blowing Fuses

My BASH 300S started blowing fuses. I removed the amp and found a blown component. It is marked on the board as "R400" and on the component is "SCK 104". Research indicates that this is some type of thermistor -- but I have no idea what the specs are or where to get a replacement.

Does anyone know what the actual specs are on the component and where to get a new one?

Also, is this indicative of another problem in the amp that may be causing an over-current condition? I didn't see any other components that looked damaged. Or can these blow just from getting old and out of spec?

Thanks for any help,
Cheryl
  Reply With Quote
Old 26th February 2012, 11:51 PM   #2
diyAudio Member
 
Join Date: Apr 2002
Location: Texas
http://www.rihengqiang.com.cn/admin/...9171135515.pdf
10 ohm 4A

I'd rather a fuse blow than a thermister!
Try slo-blow fuse per spec.
Likely something else also wrong.
  Reply With Quote
Old 26th February 2012, 11:58 PM   #3
cheryl is offline cheryl  United States
diyAudio Member
 
Join Date: Jul 2010
The fuse did blow, and it is the proper fuse (3.15A, 250V, Slow-blow). So, I guess it is likely that something else is wrong in addition to the thermistor and the fuses blowing.

Thanks for the info!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash 300s digital amp ???? bostonswoop Subwoofers 10 24th June 2007 10:50 PM
Why are these fuses blowing Darin P-B Solid State 41 30th May 2005 10:56 PM
Blowing fuses balance Tubes / Valves 2 5th March 2005 02:16 AM
blowing fuses homegrown45167 Car Audio 2 22nd October 2004 12:16 PM
The Fuses Just Keep Blowing raffir Chip Amps 19 22nd June 2003 03:49 AM


New To Site? Need Help?

All times are GMT. The time now is 03:39 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2