Mirage PS-12-180 subwoofer - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th April 2011, 04:24 PM   #1
quaddo1 is offline quaddo1  Sweden
diyAudio Member
 
quaddo1's Avatar
 
Join Date: Jun 2007
Default Mirage PS-12-180 subwoofer

Hi all,

I'm currently trying to repair an old Mirage PS-12-180 subwoofer (220V AC spec) that has died on me.

The first troubles I experienced with this unit began approx 5 years ago when it started making a humming noise from cold start/boot. The noise always stopped after approx 30 secs, and then the unit would operate normally after that.
Now when pushing the power-button it makes a sound just like it did when working, but the LED does not light up, even after waiting more than 5 secs. So I suppose the component(s) that wasn't working 100% when cold has now stopped working altogether.

I'm thinking in the line of replacing some of the capacitors, and other components that seems to have been running hot during its lifetime (i.e. dark/black areas on the board.


Any service tips or suggestions are most welcome.

Thanks in advance.

Last edited by quaddo1; 5th April 2011 at 04:30 PM.
  Reply With Quote
Old 8th April 2011, 11:32 AM   #2
diyAudio Member
 
Join Date: Mar 2007
Location: Columbus, Ohio ^
Hi quaddo1,

I am not a pro at electronics repair & will let others help you with your troubleshooting, but I did see your post in my thread & figured Id pop in here with a quick reply.

My suggestion would be to contact the Mirage company for a schematic for your PS-12-180 as it will help during your repair. If you have not done so already!

I am not sure if they will be able to supply you the schematic to your particular unit, but it never hurts to ask.

Sorry I am not much help, but I do hope someone will be able to help you out on this, there are some very knowledgeable people here on the forum. Having the schematic would make it easier for someone to tell you what to check.

I hope you get the subwoofer going again!

Take care!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repairing a Mirage PS-12-90 Powered Subwoofer amp (info needed) Pioneer621 Chip Amps 10 6th July 2013 06:43 PM
FS: Exodus Tempest-X 15" Subwoofer - $180 (SoCal pickup only) Aaron909 Swap Meet 0 6th November 2009 06:50 PM
Ucd 180 as subwoofer amp ? Buzzy Class D 7 1st July 2007 05:25 PM
What are specs for Mirage BPS-100 subwoofer drivers mokus Subwoofers 5 22nd March 2007 02:47 AM
FS: 12" Sub drivers, Marchand XM1 w/PS nodiak Swap Meet 8 26th January 2007 07:05 PM


New To Site? Need Help?

All times are GMT. The time now is 03:44 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2