velodyne hgs10 - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 10th December 2010, 05:52 PM   #1
diyAudio Member
Join Date: Jan 2007
Location: San Jose Ca.
Default velodyne hgs10

I have a Velodyne HGS 10 Mark 2 that has stopped working properly. All I get from it is a hum/ feedback sound. I've contacted Velodyne and am waiting on a RMA# so I can take it to them for repair. I was tempted to take it apart and just see if anything looked obviously afoul but I'm hesitant. Probably best to let Velodyne check it out? Their just down the road in Morgan Hill so I could easily drop it off. Anyone have experience with with Velodyne's service department?
Thanks, John
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Velodyne SMS-1 Buildsafire Class D 0 4th December 2010 09:20 PM
VELODYNE 110V to 220V iblieve Power Supplies 1 11th May 2009 08:25 PM
velodyne f 1500 help daran Subwoofers 0 30th December 2007 11:53 AM
velodyne sub problem steven344 Subwoofers 2 22nd May 2006 07:26 AM
Velodyne T/S measurements logonwheeler Subwoofers 0 18th December 2005 08:07 AM

New To Site? Need Help?

All times are GMT. The time now is 08:09 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2