Klipsch KSW10 Subwoofer - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th September 2010, 04:58 AM   #1
diyAudio Member
 
metalwheel's Avatar
 
Join Date: Sep 2010
Location: daytona beach
Question Klipsch KSW10 Subwoofer

Ok, so after a few hours of unsuccessfully searching for a replacement amplifier for this powered subwoofer, I somehow came across this forum and figured what the heck...I am not a 'Tech' guy, but do have a basic understanding of elecrticity, so here goes: The sub was working fine until played at VERY high volume level, then just went dead. First, checked fuse, fuse looked ok, but went to the local Radio Shack and bought new fuses of same rating...nothing. This, of course, one month after warranty expiration...Great. Sat in my closet for about a year then today, I decided to 'take a look-see'.

Removed amp from enclosure, gave it a visual check, no signs of overheating, leakage or anything obvious. Power supply (Transformer?) has 110 volts coming to it. Checked resistance of several components on the board, all were ok, but many, many more need checked. I have a VOM that I really don't have a lot of faith in, so I got discouraged , and impatient. This led to me to re-attach two small plugs back to the board, one is for the LED indicator...well, somehow I broke the solder joint. Broke out the soldering iron and resoldered the joint, but not very well...I guess you need a really fine point gun for this (duh) and I damaged the board in doing so...not very smart, eh? Then, I read somewhere that Vibration may have caused a weak joint to fail...possible. I'm sure a capable repair person could figure this out rather quickly, but I don't have the budget for this (sound familiar?) Any ideas??
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Klipsch Efficiency markkanof Multi-Way 9 6th December 2011 04:07 PM
200watt Klipsch Plate amp Subwoofer NICE Zero Cool Swap Meet 8 11th June 2010 03:25 AM
Okay, let me ask about Klipsch... ptwining Multi-Way 19 6th August 2006 04:11 AM
Klipsch Drivers Bill Ross Multi-Way 1 13th July 2003 05:51 PM
Value - Klipsch KG 4.5 JDeV Multi-Way 6 11th June 2003 06:05 PM


New To Site? Need Help?

All times are GMT. The time now is 11:57 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2