KEF PSW 2150 Need Schematic - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th July 2009, 10:26 PM   #1
skeoch is offline skeoch  United States
diyAudio Member
 
Join Date: Jul 2009
Default KEF PSW 2150 Need Schematic

I need to repair my PSW 2150 Sub-woofer and the only schematic that I have is for the PSW 2000. It is close in many areas but of course my problem is not common to both models. Any help is greatly appreciated.

Regards,

John

john_skeoch_1964@q.com
  Reply With Quote
Old 2nd August 2009, 01:46 AM   #2
diyAudio Member
 
Join Date: May 2002
Default PSW-2150 - hum/noise

Hi,

What issue are you having with your KEF 2150 ?

I will turn mine on and after ~ 20 seconds or so, I get a hum type noise with volume turned down. With volume up, bass is popping and distorted.

Any help ?

Thanks !!

feke67
  Reply With Quote
Old 2nd August 2009, 10:19 AM   #3
skeoch is offline skeoch  United States
diyAudio Member
 
Join Date: Jul 2009
Good evening,
I started out with a bad filter capacitor for the 'muting' relay then after a few hours of normal operation one of the power transistors shorted. In the process of making that repair I found that the heat sink to the out side of the case only had about 1/3 of the area covered with thermal compound. I did move the +- 15 volt regulators on to the same heat sink as the power transistors hoping to reduce some of the internal heat build up. If possible I would like to add a small fan to help lower the internal temperature. I'm about ready to put the amp back into service when i have a few spare minutes.

If you do not have a schematic for your amp I do have one available and would post one to you if you need it. I tried to ansewer you directly but I guess I haven't posted enough times to do that.

If I can off any more assistance please let me know. Sometimes I can be a little slow in answering as I am medically retired and some times I'm not up to checking my mail but I do get to eventually.

Regards,

John
  Reply With Quote
Old 24th February 2010, 02:15 AM   #4
diyAudio Member
 
Join Date: Feb 2010
Default Kef psw2150

Good evening,

I have had a coupe problems with my sw. The transformer went bad. then two filter caps were swelled up. I replaced them a few years ago but now I have no sound what so ever coming out. does anyone have any ideas on what could be wrong or does anyone have a schematic for the amp? I want thak you ahead of time or what you can do to help me. THANK YOU.

From Brad
  Reply With Quote
Old 11th April 2010, 09:02 AM   #5
diyAudio Member
 
Join Date: Feb 2010
Location: Czech
Quote:
Originally Posted by skeoch View Post
I need to repair my PSW 2150 Sub-woofer and the only schematic that I have is for the PSW 2000. It is close in many areas but of course my problem is not common to both models. Any help is greatly appreciated.

Regards,

John

john_skeoch_1964@q.com
Attached Files
File Type: zip kef_psw2010_sm.zip (684.1 KB, 214 views)
  Reply With Quote
Old 7th June 2010, 08:51 PM   #6
diyAudio Member
 
Join Date: Jun 2010
I have been after the info for the PSW2500 so thanks for posting the file :-)
  Reply With Quote
Old 27th January 2011, 11:28 PM   #7
diyAudio Member
 
Join Date: Jan 2011
I know this is a bit of an old thread, but maybe you can help. I have this sub and it seems to work fine, then after a bit of playing...anywhere from 30min to an hour, I'll get a strange hum, buzz, distortion noise through it. It appears to be regardless of source, and it will continue even if the receiver is turned off. My best guess is something in the power supply, but I don't know for sure. It will last anywhere from 1 second to however long it takes me to jump up and unplug it. When it goes away or when I plug it back it, it plays just fine. Any suggestions on where to start? I have a service manual for it and I don't mind replacing PCB components. Thanks for any help you can offer.
  Reply With Quote
Old 17th November 2011, 03:36 PM   #8
diyAudio Member
 
Join Date: Nov 2011
Quote:
Originally Posted by skeoch View Post
Good evening,
I started out with a bad filter capacitor for the 'muting' relay then after a few hours of normal operation one of the power transistors shorted. In the process of making that repair I found that the heat sink to the out side of the case only had about 1/3 of the area covered with thermal compound. I did move the +- 15 volt regulators on to the same heat sink as the power transistors hoping to reduce some of the internal heat build up. If possible I would like to add a small fan to help lower the internal temperature. I'm about ready to put the amp back into service when i have a few spare minutes.

If you do not have a schematic for your amp I do have one available and would post one to you if you need it. I tried to ansewer you directly but I guess I haven't posted enough times to do that.

If I can off any more assistance please let me know. Sometimes I can be a little slow in answering as I am medically retired and some times I'm not up to checking my mail but I do get to eventually.

Regards,

John
Hi - I am attempting to resurrect this old thread to see if I can get some help for my 2150 PSW. It lights up and seems to sense the input, but I get nothing for output....any help is appreciated!!
  Reply With Quote
Old 22nd November 2011, 05:56 PM   #9
diyAudio Member
 
Join Date: Nov 2011
Hi Kwaskow,

I have the KEF PSW 2150 as well. It worked fine for about 4 years and recently, when you first send a signal by turning on the receiver, all you hear is a buzzing sound. When sound signals are actually sent from a movie / game, etc there is cracking and popping.

It would be nice to see a schematic and or advice from someone who know's what parts could be bad. Possibly how to diagnose?

Thanks,
Garrison777
  Reply With Quote
Old 23rd November 2011, 06:56 PM   #10
diyAudio Member
 
Join Date: Nov 2011
bump - anyone?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 2150/3150 Schematic + advice steve_aus Solid State 1 22nd November 2011 06:15 PM
Help with Orion 2150 Gx v-dub-guy Car Audio 7 20th January 2008 02:25 AM
xtr 2150 shorting out. 1armed1 Car Audio 9 20th April 2007 06:56 PM
orion xtr 2150 mike49504 Car Audio 11 1st October 2006 12:19 AM


New To Site? Need Help?

All times are GMT. The time now is 03:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2