subwoofers included but not sure where to post.... - diyAudio
Go Back   Home > Forums > Loudspeakers > Subwoofers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th June 2009, 04:26 AM   #1
lebatt is offline lebatt  Canada
diyAudio Member
 
Join Date: Jun 2009
Default subwoofers included but not sure where to post....

Hi,

Ok, I've been on a tight, tight budget since I sold my big stereo and had kids. I had 4 towers, 4 subs, huge center and 2 bookshelf surrounds. I know the brand sucked but it's Nuance. And no i didnt overpay bought used but the price was good.

Anywhoo.. that was to let you know my main old system. Now onto my budget system. Based on logitech/energy encore2's.

Ok, so Here was my setup I had a Logitech sub 120rms and 2 sattellite speakers 40wrms each i think. Then i Picked up a Z400, which consists of, 180rms sub, and i think 40w rms satellites (4).

Then I hooked my aura bass shakers up to my amp (through the port) wired in a series at 8 ohms, but I overloaded my amp. I didnt realize i was putting a 16 ( i think ) ohm load on it. As it was connected to a 8 ohm sub, then wired to 8 ohms for the 2 bass shakers. (50W Pro's).

Everything is hooked up via RCA to Stereo jack, then split to the systems.

Since that amp blew, I kept the sub/box, and the 4 speakers. So now I Re-split to a sony amp which powers my 4 Energy encore2's.

So basically the logitech's are my subs and the encores are my fronts.

I have 3 aura bass shakers, and picking up tomorrow a Logitech Z-2200 system, The reason is I'm going to unhook the sub and use the amp to power my 2 aura bass shakers. I'll re-wire them for a 8 ohm load and then unhook the sub/2 satellites so that amp is powering the bass shakers alone.


Sorry for the long speal here, but what do you think? It shakes my wall and floor a bit, sounds great, the encore's are good (to believe they almost threw them away, I got them for free, (had to add so you can see the budget part of my system was a total cost of.. 260 total))

I can hook up my 4 satellites to the Z-400's and have 8 fronts basically.

LASTLY..

I was thinking on hooking up a computer to the front again with a 5.1 sound card, so I can stereo jack the 2 back speakers into surround, the fronts being the 4 logitech sattelites, and the 4 encore2's being my center for better clarity.

So what do you think?
Thanks for reading this, It may be a little confusing, I hope not but Next year I'm going to buy a nice xpensvie HDMI amp and use the encore2's properly, along with the satellite speakers I will unhook them and use them as surrounds. Then buy a proper sub and convert the rest into a car system.
  Reply With Quote
Old 6th June 2009, 01:14 PM   #2
diyAudio Member
 
chris661's Avatar
 
Join Date: Feb 2008
Location: Sheffield
Blog Entries: 8
I don't think the load you put on the amp was 16ohm. This wouldn't have blown it, so you would have gone the other way, to 4ohms perhaps...

It all sounds like you're going to need a lot of wires. if you power everything with the Sony, you should be Ok.

With that many speakers, you could go for a 7.1 surround...

I've been in similar situations, with lots of powered speakers and a computer.

Good luck with it. Mess around with it until the sound couldn't be any better, then sit back and enjoy.
__________________
"Throwing parts at a failure is like throwing sponges at a rainstorm." - Enzo
My setup: http://www.diyaudio.com/forums/multi...tang-band.html
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anybody know anything about this amp? STUDIOCRAFT F1 (see picture included) dean ashmore Solid State 0 16th November 2008 08:08 AM
Grounding Check please (diagram included) redrabbit Solid State 10 15th October 2007 08:52 AM
BSOZ Works! (but only 1/3 Done, pics included) lgreen Pass Labs 11 17th July 2003 04:26 PM
Alephs included in Stereophiles 100 hot components protos Pass Labs 16 18th November 2002 04:40 PM


New To Site? Need Help?

All times are GMT. The time now is 06:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2