Oscillations in P3A ?? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th January 2003, 09:03 AM   #1
diyAudio Member
 
Join Date: Sep 2002
Location: Denmark
Question Oscillations in P3A ??

Pls help !

I have build several versions of P3A and they where fine. I have now a +/- 42 volt version and it is oscillating very hard - 20 volt p/p probably in the Mhz area. All caps ara mounted but nothing helps. What to do ? the output is 2SC3281/2SA1302.
Btw, if i drive it hard (input 2v p/p) @ 1 Khz it stops oscillating and act OK.
  Reply With Quote
Old 16th January 2003, 09:41 AM   #2
trwh is offline trwh  United Kingdom
diyAudio Member
 
trwh's Avatar
 
Join Date: Apr 2002
Location: UK
Hi

Are you sure your output devices aren't fakes? The 2SC3281/2SA1302 parts you mention were discontinued some time ago. Check here:

Toshiba 2SC3281/2SA1302 - Are these fakes?
  Reply With Quote
Old 20th January 2003, 07:58 AM   #3
diyAudio Member
 
Join Date: Sep 2002
Location: Denmark
Thanks for the advice, but still i think the design shoul work.
Can anyone explain ??

I am kind of desperate.
  Reply With Quote
Old 20th January 2003, 09:34 PM   #4
diyAudio Member
 
Join Date: Aug 2002
Location: Farmington, CT
Send a message via AIM to Mattyo5
Have you contacted Rod Elliot about it? It does sound to me like those chips need to be replaced. I don't know about where you are, but here, Digikey has the new Toshiba chips for like $2 each. The 2sc5200 and the 1943? Cheap enough. Contact Rod Elliot and let us know what he says about it.

-Matthew K. Olson
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chip Amp Oscillations!!! john65b Chip Amps 10 30th December 2007 03:31 PM
oscillations IN OPAMP help ???? prorms Solid State 3 30th September 2007 12:17 PM
How to test for oscillations? Jye Chip Amps 13 20th October 2004 11:56 PM
amplifier oscillations lowfi Pass Labs 33 29th May 2002 07:32 PM
Aleph 3 oscillations Koy Pass Labs 4 22nd April 2002 04:56 PM


New To Site? Need Help?

All times are GMT. The time now is 07:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2