Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st April 2007, 04:14 PM   #1
diyAudio Member
 
Join Date: Apr 2007
Default Fixing / Trouble shooting Cyrus SmartPower

Hi all,
I have a Cyrus smartpower (newer version with the plastic base).
When I fick the power switch on both the 'power' and 'mono' lights turn red for a second then fade off. The 'power' light then comes on green with the 'mono' on red for a second before they fade off again then it enters standby.
Pressing the standby button just gives me the flashing red light.

I have opened it up and both the fuses have blown. I replaced them and they both blew as sone as I turned it back on - nothing connected apart from the power lead.

Any ideas whats causing it or how I can find out?
Sending it back to Cyrus is not one of the options!

Many thanks
  Reply With Quote
Old 8th April 2007, 01:04 AM   #2
diyAudio Member
 
Sonusthree's Avatar
 
Join Date: Dec 2005
Location: Sussex, UK
Default Re: Fixing / Trouble shooting Cyrus SmartPower

Hi,
Do you own and know how to use a multimeter? Maybe someone here can guide you.
From what I hear that amp is a little fiddly because of the SMD components used but you never know until you try! (safely of course.)

...... and welcome to the forum.

Martin.
__________________
Martin
+ + =
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Op amp trouble shooting Bose(o) Chip Amps 13 1st April 2005 07:37 PM
trouble shooting my DD receiver kslim Solid State 0 1st December 2004 12:21 AM
Help trouble shooting Christof Tubes / Valves 11 1st September 2004 02:27 AM
need some trouble shooting help Jean Solid State 41 7th October 2002 04:53 AM
Trouble shooting help NerdMike Solid State 2 29th September 2002 12:34 AM


New To Site? Need Help?

All times are GMT. The time now is 01:30 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2