Need Bias Help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd February 2007, 11:54 PM   #1
diyAudio Member
 
Join Date: Nov 2006
Default Need Bias Help

This is my first thread ever so bear with me. I have several Soundcraftsmen PCR800 Amps, these amps orginally came with four mosfets output transistors per channel. The board and heatsinks were set up for six.
I have added two more mosfets per channel, as per soundcraftsmen schematic. However the schematic doesn't tell how to set the Bias so I need help here.
I also have read that these mosfets should be matched, the problem is they are no longer available, so how critical is this match?
  Reply With Quote
Old 4th February 2007, 11:26 AM   #2
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi,
the larger the source resistor value the less critical the matching.

With 0r22 and three pairs I think there will be problems getting the stages to run with similar temps in each.

With 0r47 you might be in the ballpark, but 0r68 would probably be better.
What did Soundcraftsmen fit?

I expect the Bias to be set by adjusting the voltage on the gates to effectively control Vgs. When you add an extra parallel FET it also sees the same Vgs and will draw it's own quiescent current.
Effectively the bias will have correctly increased by 50% and dissipation will also be +50%. It's going to run hotter unless you have increased the sinks to dissipate the extra heat.
__________________
regards Andrew T.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing grid leak bias preamp to cathode bias bereanbill Tubes / Valves 8 28th March 2009 05:26 PM
Bias problem- 1 Socket shows extremely low bias! otokomae Tubes / Valves 12 31st December 2008 10:01 PM
Stray hum pickup *preamp* cathode R-bias vs. battery bias & 12AU7vs.5687 awedio Tubes / Valves 2 19th April 2008 01:30 AM
Battery grid bias to fixed bias in Toccato? w00t Tubes / Valves 3 2nd December 2007 12:34 AM
Supressed bias amplifier, automatic variable bias system. destroyer X Solid State 2 20th September 2004 10:24 AM


New To Site? Need Help?

All times are GMT. The time now is 04:50 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2