kenwood KAC 1020 amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th January 2003, 04:10 PM   #1
diyAudio Member
 
Join Date: May 2002
Question kenwood KAC 1020 amp

kenwood KAC 1020 car amp, i need some output specs as i got this amp without a manual, however no-one on and off the net has heard off it. Two channel, black, big and heavy about 10-12 kg's and comes with 4 x 15 amp fuses. Guys - throw me a ******* bone....for pete's sake. NB Its two channel 'cos it has diagrams for bridge mode.
  Reply With Quote
Old 6th January 2003, 04:23 PM   #2
jc2 is offline jc2
diyAudio Member
 
Join Date: Dec 2001
Location: Atlanta, Georgia
200x2 at 4 ohms, 600x1 at 4 ohms.

Good amp, I had one back in 93.
  Reply With Quote
Old 6th January 2003, 04:32 PM   #3
diyAudio Member
 
Join Date: May 2002
so its 2 ohm stable with 300W rms output, any chance of a manual?
  Reply With Quote
Old 6th January 2003, 04:44 PM   #4
diyAudio Member
 
Join Date: May 2002
I paid about the equivalent of $30 for this amp, in stereo mode only the right channel works and in bridge mode it works. Any ideas as to whats happening with the left channel?
  Reply With Quote
Old 7th January 2003, 04:30 PM   #5
diyAudio Member
 
Join Date: Sep 2002
Location: Raleigh NC
Send a message via AIM to Jared
you have the same symptoms I had when repairing an amp where the gain knob was broken. Turns out htere was somehting wrong with the ground ( I dont remember exactly) where I had made a solder bridge.. so bridged worked, but only one channel at a time worked, as once the RCA in's made a ground for that channel it cut out or somehting liek that... test the variable resistor that is the gain knob, and also try to plug in only one RCA ata time and see if that helps.

Of course, you could also just have one blown channel ???
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 1020 Preamp Problems gmilitano Solid State 55 22nd May 2012 04:05 AM
Please help with NAD 1020 Pre-amp pureh2o Solid State 12 18th October 2008 09:39 PM
Kenwood KAC 1020 Schematics needed Tom7227 Car Audio 1 25th November 2007 07:20 PM
FS: Lightware L-1020 projector Lusso5 Swap Meet 0 27th January 2005 04:49 PM


New To Site? Need Help?

All times are GMT. The time now is 04:34 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2