Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Technics SU-A900mk2 puzzle
Technics SU-A900mk2 puzzle
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th January 2007, 06:51 PM   #1
Owlesque1 is offline Owlesque1  United Kingdom
diyAudio Member
 
Join Date: Jan 2007
Location: England
Default Technics SU-A900mk2 puzzle

Hi all. Wondered if any talented persons could shed a light on this: Just got hold of my late grandfather's perfect condition, unused Technics SU-A900mk2 amp, and it doesn't make sound. Bought new about '97, and only used for a few hours ever.

The standby light comes on, then you click the power switch, the speaker selection light is on, the input selector and lights work, the remote control works the functions, but the 'OPERATION' light remains off, and no sound from the speakers. Fuse is fine, though I'm surprised there's only one. Above the Opereation light, it says 'virtual battery operation'. What does this mean, and could it be the source of the malfunction?.

It looks absolutely mint inside and out otherwise, so I don't know where to start.

Can anyone help?

Regards, Lee.
  Reply With Quote
Old 27th January 2007, 09:51 PM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Technics SU-A900mk2 puzzle
Hi Lee,
I'm not familar with that model. I do know they suffered from many cracked solder connections. I hope that a tech who knows this amp can tell you what your error message is and what it means in a real sense.

Failing that, if you can solder well, take it apart and resolder connections near the heatsink and rear panel on the main board. Do not use too much solder. Solder flux is great here.

-Chris
  Reply With Quote

Reply


Technics SU-A900mk2 puzzleHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cd 650 puzzle guido Digital Source 13 4th May 2015 08:33 AM
Technics SU-A900Mk2 OXAUDIO Chip Amps 14 24th October 2012 01:50 PM
TO3 puzzle Zen Mod Parts 2 3rd December 2006 10:45 AM
help me with this puzzle... AudioGeek Tubes / Valves 3 21st May 2005 07:48 PM
Puzzle dhaen The Lounge 1 5th August 2004 01:00 AM


New To Site? Need Help?

All times are GMT. The time now is 08:48 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki