Is it a bad relay? - Rotel 990BX - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th January 2007, 06:57 PM   #1
sam562 is offline sam562  United States
diyAudio Member
 
Join Date: Oct 2006
Default Is it a bad relay? - Rotel 990BX

Hi,

I have a Rotel 990BX Power amplifier that I think has a bad relay:

With the preamp on and music playing, when you switch the Rotel:

*ON* - Right speaker comes on immediately, then after a 3-counts, the protection light goes off and Left speaker comes on.

*OFF* - Protection light and Left speaker go off immediately - Right speaker trails off like when you lose a radio station driving through the sparser parts of New Mexico.

The protection/relay is supposed to mute both speakers on power up so there is no "pop", also it mutes them on power down - I think its just not working for the right side

I took it by a local electronics repair place and after plugging it in and turning it on, they said that it was obviously something major since they could hear the relay/protection circuit engage and disengage, therefore something was shorted and dangerous DC voltage was going to fry my speakers. I did thank him and offered to pay him for his advice but he refused. Could he be right though?

Rotel 990BX relay

Thanks!
- Sam
  Reply With Quote
Old 16th January 2007, 07:00 PM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi Sam,
Replace that relay. The contacts on one side are oxidized and not making contact. It is supposed to mute the input. Also check the connecting wires.

-Chris
  Reply With Quote
Old 16th January 2007, 07:09 PM   #3
sam562 is offline sam562  United States
diyAudio Member
 
Join Date: Oct 2006
Thanks anatech,... I'm on it.

What a goldmine this forum is!
  Reply With Quote
Old 26th January 2007, 09:31 PM   #4
sam562 is offline sam562  United States
diyAudio Member
 
Join Date: Oct 2006
Well, I replaced the relay and it still had the same problem!

After a few hours of trying to figure out what it could be I noticed that the stripe on one of the 3-wire internal cables leading to the relay pcb wasn't going to the dot marking on the connecter, it was reversed.

Of course it worked perfectly after I flipped it around...lol

Ah well, at least I know the relay is fresh!

Thanks again for your help,
-Sam
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Manual/ schematic for Rotel ROTEL RHCD-10 Michi CD player Staykov Digital Source 5 16th May 2012 12:24 AM
A couple questions about blown output fuses, and protection (Rotel RT-990BX) terasearch Solid State 3 2nd August 2009 11:50 AM
Rotel Amp mute relay/cap? toolkit Solid State 4 3rd November 2007 06:09 PM
Rotel RB-990BX Supply Voltage tab30 Solid State 4 22nd August 2003 03:09 PM


New To Site? Need Help?

All times are GMT. The time now is 08:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2