Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

NAD 3020 amplifier volume problems
NAD 3020 amplifier volume problems
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th December 2006, 09:15 PM   #1
Neilb is offline Neilb  United Kingdom
diyAudio Member
 
Join Date: Dec 2006
Default NAD 3020 amplifier volume problems

My 25 year old NAD 3020 has suddenly lost volume. It was working fine but suddenly went 'quiet'. If you go close to speakers, you can hear music very faintly. Any idea what problem is and if t can be easily fixed orhas it just come to en dof useful life? The same problem was raised by 'diddytong' in july 2005. Help!
  Reply With Quote
Old 20th December 2006, 03:40 AM   #2
N-Channel is offline N-Channel  United States
diyAudio Member
 
N-Channel's Avatar
 
Join Date: Mar 2003
Location: Sol System
Send a message via AIM to N-Channel
Default NAD Volume Control

Hi Neil,

I love NAD products! I have an older 2200PE Amp and 1155 Preamp. Also have a 7225PE receiver. All work beautifully! Something really cool about an S/N Ratio of 114dB! I bought my 1155 second-hand from a pawn shop a few years ago and had problems with the volume control (noisy and music would cut out entirely sometimes). I replaced it with a new one, and Voila! Problem gone.

Since you're still hearing music faintly, your amplifiers are functioning. If the volume control is not suspect, then I would check any logic-controlled muting circuits to see if they're acting up.

Since I am unfamiliar with the 3020, I would ask: Does it use a true analogue potentiometer or a rotary encoder with digital volume control?

Sorry to present you with more question than answers, but these are a few things you might try out first.

Hope this helps out!

Kind Regards,

Steve
  Reply With Quote
Old 20th December 2006, 03:51 AM   #3
planet10 is offline planet10  Canada
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
NAD 3020 amplifier volume problems
Default Re: NAD Volume Control

Quote:
Originally posted by N-Channel Does it use a true analogue potentiometer
yes

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 20th December 2006, 03:35 PM   #4
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi,
very faint sounds like you are hearing crosstalk.
Is the input selector working correctly?

Switch off, swap leads to another input and check again.
__________________
regards Andrew T.
  Reply With Quote
Old 20th December 2006, 08:33 PM   #5
Neilb is offline Neilb  United Kingdom
diyAudio Member
 
Join Date: Dec 2006
All connections are correct - it was playing normally and volume just 'went'.
  Reply With Quote
Old 20th December 2006, 08:49 PM   #6
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
Schematic is here:
http://www.tcaas.btinternet.co.uk/index-4.htm
As a starter, you could measure at the pre-out/power-in connection.

/Hugo
  Reply With Quote
Old 20th December 2006, 09:26 PM   #7
planet10 is offline planet10  Canada
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
NAD 3020 amplifier volume problems
Here is the (early) 3020 service manual [11MB] ....

http://p10hifi.net/tlinespeakers/TLS...viceManual.pdf

and the 3020B schema

http://p10hifi.net/tlinespeakers/TLS..._schematic.gif

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 21st December 2006, 12:44 AM   #8
gmilitano is offline gmilitano  Canada
diyAudio Member
 
gmilitano's Avatar
 
Join Date: Apr 2004
Location: Winnipeg, Manitoba
This thread has my experience with a very similar problem and the NAD 1020:

http://www.diyaudio.com/forums/showt...threadid=62671

The 1020 is essentially the same preamp section of the 3020.

I had to remove the muting resistors. Play around with headphones and see if you have a signal in trhe preamp section. Or you can try put a signal into the amp section. That way you will know what section has the problem.
  Reply With Quote

Reply


NAD 3020 amplifier volume problemsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nad 3020 problems reddish75 Solid State 0 19th May 2008 09:03 PM
problems with diy amplifier technics Solid State 4 23rd May 2003 07:30 PM
Annoying problems with Volume pot stigla Solid State 3 4th November 2002 12:08 PM
Amplifier problems... Diogo Solid State 1 31st August 2002 11:11 PM
NAD 3020 problems Neopsp Solid State 2 17th May 2002 03:34 AM


New To Site? Need Help?

All times are GMT. The time now is 03:09 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki