Marantz PM-66SE: No audio - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th November 2006, 07:59 AM   #1
diyAudio Member
 
Join Date: Nov 2006
Default Marantz PM-66SE: No audio

Hi guys,

I have a Marantz PM-66SE and now it is not outputting any audio.

Is power up, but no audio for CD player and tuner. What could be the problem? I have tested the speaker, speaker is working.

*by the way, where can I online order spare parts for Marantz PM66SE?


Cheers,
Jason
  Reply With Quote
Old 8th December 2006, 01:54 AM   #2
diyAudio Member
 
Join Date: Oct 2006
Location: Cleveleys, Lancashire
Hi if you have not already fixed this I had the same problem. Check R802 and/or R807.
They should be 47 ohm resistors and seem to be used as fuses.
here is a link to the thread I found
Marantz PM 66SE KI Signature. Newbie Question
  Reply With Quote
Old 19th October 2007, 03:04 PM   #3
ymong is offline ymong  Singapore
diyAudio Member
 
Join Date: Oct 2007
I've the same problems with my PM66SE KI, Measured the resistor as suggestted R802 & R807, both given 47 Ohm on my digital multi meter, What else could be the problems? anybody experience the same care to share?

Thank You & Cheers
ymong
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
marantz PM-66SE kinvig Solid State 2 3rd April 2008 12:46 AM
Problem with Marantz PM-66SE amplifier channel3 Solid State 4 5th January 2008 08:29 PM
Marantz PM-66SE Repair Thread poynton Solid State 0 29th December 2007 08:35 PM
Marantz PM-66SE Blown Channel Chudley Solid State 2 8th May 2007 08:28 PM
Marantz Pm-66SE geddam Solid State 2 28th April 2005 03:15 AM


New To Site? Need Help?

All times are GMT. The time now is 12:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2