fried input..? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th December 2002, 02:20 AM   #1
diyAudio Member
 
Join Date: May 2002
Location: London, Ontario
Default fried input..?

i just recently got an old 1978 jvc jr-s501 receiver....

im using it to power 2 sub's i got..

b4 the receiver i have active crossover...

my question is let's suppose one for a split fraction of second had the gain on the crossover turned up just a bit tooo high..

could this possibly fry or damage the input for the receiver..

if so how would one attempt to fix this if the input are in fact damaged?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fried t-amp? kaban Class D 24 23rd June 2006 09:03 AM
Fried New Amp memito Car Audio 8 10th August 2004 01:38 AM
$5 SE amp... but is it fried?! SHiFTY Tubes / Valves 3 18th January 2004 03:13 PM


New To Site? Need Help?

All times are GMT. The time now is 02:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2