help with models. - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th October 2006, 03:19 PM   #1
diyAudio Member
 
bogdan_borko's Avatar
 
Join Date: Nov 2005
Location: serbia, zajecar
Default help with models.

does anyone have spice models for these devices that work good with CIRCUIT MAKER?

2sk170 / 2sj74
2sk1058/ 2sj162
  Reply With Quote
Old 19th October 2006, 06:40 PM   #2
diyAudio Member
 
Join Date: May 2005
Location: Cacak, Serbia
*2SJ74
*Toshiba Dep-Mode 20mA 400mW LowNoise pkg:TO-92B 2,1,3
.MODEL 2SJ74 PJF(Beta=92.12m Rs=7.748 Rd=7.748 Lambda=4.464m
+Vto=-.5428 Cgd=85.67p Pb=.3905 Fc=.5
+Cgs=78.27p Is=12.98p
+Kf=26.64E-18 Af=1)

*2SK170
* 20mA 400mW LowNoise Dep-Mode pkg:TO-92B 3,1,2
.MODEL 2SK170 NJF(Beta=59.86m Rs=4.151 Rd=4.151 Lambda=1.923m
+Vto=-.5024 Cgd=20p Pb=.4746 Fc=.5
+Cgs=25.48p Is=8.477p
+Kf=111.3E-18 Af=1)
__________________
Laonicus Chalcondyles : “Tryballos, Serbos, autem gentem esse totius orbis antiquissimam et maximam, compertum habeo...”
  Reply With Quote
Old 19th October 2006, 06:56 PM   #3
diyAudio Member
 
bogdan_borko's Avatar
 
Join Date: Nov 2005
Location: serbia, zajecar
thaks a LOT! (boro care! PoZdrav!)

wath about lat.mosfets?
  Reply With Quote
Old 11th November 2006, 02:50 AM   #4
lineup is offline lineup  Sweden
diyAudio Member
 
lineup's Avatar
 
Join Date: Dec 2005
Location: the north
Default Re: help with models.

Quote:
Originally posted by bogdan_borko
does anyone have spice models for these devices
that work good with CIRCUIT MAKER?

2sk170 / 2sj74
2sk1058/ 2sj162

Quote:
Originally posted by bogdan_borko
thanks a LOT! (boro care! PoZdrav!)

what about lateral mosfets, 2SK1058 / 2SJ162 ?

I'd like also to get working Lateral MOSFET models.
I use Electronics Workbench Multisim.

Besides 2SK1058 / 2SJ162, I want: 2SK1530 / 2SJ201

If anybody has got a good models of 2SK216 / 2SJ79 that works with Multisim.
I would be most happy!
--------------------------------------------------


I tried Netlist contributed 2SK216 model. I am sure it is good.
But I just get an error message. What am I doing wrong?
Quote:
.MODEL 2SK216 NMOS (VTO=-56.0259M KP=20U L=2U W=10.3184M GAMMA=0 PHI=600M
+ LAMBDA=2.12826M CBD=1.80316N IS=10F CGSO=1.13517N CGDO=1.13517N TOX=0 NSUB=0
+ TPG=1 UO=600 RG=50 RDS=1MEG)
----------------------------
Error on line 14 in C:\TEMP\02.CIR.cir: mu1 2 3 4 2sk216__mosfet_n__3
unable to find definition of model - default assumed
__________________
lineup
  Reply With Quote
Old 11th November 2006, 03:12 AM   #5
diyAudio Member
 
Join Date: Apr 2006
Location: Minnesota
lineup,

The last quote in post #4 has a linewrap problem, so if this is what your model statement really is, it won't work. Add a + sign to the 2 line that don't have them. The + sign means "continuation".

Rick
  Reply With Quote
Old 11th November 2006, 04:36 AM   #6
lineup is offline lineup  Sweden
diyAudio Member
 
lineup's Avatar
 
Join Date: Dec 2005
Location: the north
Quote:
Originally posted by sawreyrw
lineup,

The last quote in post #4 has a linewrap problem,
so if this is what your model statement really is, it won't work.
Add a + sign to the 2 line that don't have them.
The + sign means "continuation".
Model:
Quote:
.MODEL 2SK216 NMOS (VTO=-56.0259M KP=20U L=2U W=10.3184M GAMMA=0 PHI=600M
+ LAMBDA=2.12826M CBD=1.80316N IS=10F CGSO=1.13517N CGDO=1.13517N TOX=0 NSUB=0
+ TPG=1 UO=600 RG=50 RDS=1MEG)
This is Error I get, running above model:
Quote:
Error on line 14 in C:\TEMP\02.CIR.cir:
mu1 2 3 4 2sk216__mosfet_n__3
unable to find definition of model - default assumed
I don't understand. Is this really a linewrap problem ...
I don't think so.

lineup
__________________
lineup
  Reply With Quote
Old 11th November 2006, 11:54 AM   #7
diyAudio Member
 
Join Date: Apr 2006
Location: Minnesota
If it is written like your post, it is a linewarp problem. Try fixing it as I suggested.

Rick
  Reply With Quote
Old 11th November 2006, 02:19 PM   #8
diyAudio Member
 
aparatusonitus's Avatar
 
Join Date: Jan 2004
Location: Split, Croatia
This should help somewhat...

*SRC=2SJ76;QSJ76;MOSFETs P;Gen. Purpose;140V 500mA
.MODEL 2SJ76 PMOS (LEVEL=1 VTO=-15 KP=122N GAMMA=18.6
+ PHI=.75 LAMBDA=1.48M RD=.84 RS=.84 IS=250F PB=.8 MJ=.46
+ CBD=444P CBS=533P CGSO=384N CGDO=320N CGBO=346N)
* -- Assumes default L=100U W=100U --
* 140 Volt .5 Amp 6 ohm Enh-Mode P-Channel MOSFET 07-28-1995
* 2SJ76, TOSHIBA, 1993 JAPANESE FET MANUAL, P.16
**********
*SRC=2SJ79;QSJ79;MOSFETs P;Gen. Purpose;200V 500mA
.MODEL 2SJ79 PMOS (LEVEL=1 VTO=-15 KP=122N GAMMA=18.6
+ PHI=.75 LAMBDA=1.04M RD=.84 RS=.84 IS=250F PB=.8 MJ=.46
+ CBD=862P CBS=1.03N CGSO=57.6N CGDO=48N CGBO=1.09U)
* -- Assumes default L=100U W=100U --
* 200 Volt .5 Amp 6 ohm Enh-Mode P-Channel MOSFET 07-28-1995
* 2SJ79, TOSHIBA, 1993 JAPANESE FET MANUAL, P.16
**********
*SRC=2SK213;QSK213;MOSFETs N;Gen. Purpose;140V 500mA
.MODEL 2SK213 NMOS (LEVEL=1 VTO=15 KP=.16 GAMMA=18.6
+ PHI=.75 LAMBDA=1.48M RD=.84 RS=.84 IS=250F PB=.8 MJ=.46
+ CBD=560P CBS=672P CGSO=26.4N CGDO=22N CGBO=852N)
* -- Assumes default L=100U W=100U --
* 140 Volt .5 Amp 6 ohm Enh-Mode N-Channel MOSFET 07-28-1995
* 2SK213, TOSHIBA, 1993 JAPANESE FET MANUAL, P.38
**********
*SRC=2SK216;QSK216;MOSFETs N;Gen. Purpose;200V 500mA
.MODEL 2SK216 NMOS (LEVEL=1 VTO=15 KP=80M GAMMA=18.6
+ PHI=.75 LAMBDA=521U RD=.84 RS=.84 IS=250F PB=.8 MJ=.46
+ CBD=658P CBS=790P CGSO=26.4N CGDO=22N CGBO=852N)
* -- Assumes default L=100U W=100U --
* 200 Volt .5 Amp 6 ohm Enh-Mode N-Channel MOSFET 07-28-1995
* 2SK216, TOSHIBA, 1993 JAPANESE FET MANUAL, P.38
**********
__________________
Non é mai abbastanza...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
spice models for led fscarpa58 Parts 18 10th August 2009 10:16 PM
IR driver models darkfenriz Class D 2 5th March 2007 09:06 PM
anyone have some transformer models? keantoken Power Supplies 13 26th September 2006 03:24 AM
mje models? bogdan_borko Solid State 2 29th May 2006 11:37 PM
looking for spice models bocka Parts 16 23rd November 2003 02:00 PM


New To Site? Need Help?

All times are GMT. The time now is 05:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2