Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

popping crackling distortion that clears up after 2 mins Help!!
popping crackling distortion that clears up after 2 mins Help!!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd October 2006, 11:23 AM   #1
Puggie is offline Puggie  United Kingdom
diyAudio Member
 
Join Date: Oct 2004
Default popping crackling distortion that clears up after 2 mins Help!!

I'm having problems with a Quad 405 fitted with a frequency splitting board from a rogers LS 5/8 loudspeaker.

when powered up the Bass section pops and crackles quite loudly (almost like electrical arcing) with some background hiss, after about 2 mins it settles down and behaves. I had this problem about 6 months ago and replaced most of the transistors and capacitors (mostly Tantalums which were replaced with electrolytics) which solved the problem but now it has re-appeared, any idea what the problem could be?

thanks
  Reply With Quote
Old 2nd October 2006, 12:14 PM   #2
edl is offline edl  Hungary
diyAudio Member
 
edl's Avatar
 
Join Date: Oct 2004
What's your speakers impedance?
  Reply With Quote
Old 2nd October 2006, 12:42 PM   #3
Puggie is offline Puggie  United Kingdom
diyAudio Member
 
Join Date: Oct 2004
8ohm IIRC, I tried it on a 4ohm midbass and that is no better/worse.

I have found with just the amp channel and no input I get a little popping and crackling, with the frequency splitter board it seems a little worse (but it may not be).
  Reply With Quote
Old 2nd October 2006, 12:59 PM   #4
edl is offline edl  Hungary
diyAudio Member
 
edl's Avatar
 
Join Date: Oct 2004
Hmmm...
Then I would check the solderings, then the elkos.

Or maybe it's oscillating? You should use a scope to determine it.
  Reply With Quote
Old 3rd October 2006, 11:13 AM   #5
destroyer X is offline destroyer X  Brazil
diyAudio Member
 
destroyer X's Avatar
 
Join Date: Feb 2004
Location: Recife - Brasil Northeast
Default Try this method....and the others ideas people will suggest too.


Touch with a soldering iron the components leads

This way you may find the defective component.

Do it with the amplifier switched on...no signal in the input..and listen to detect the noise..... wait component to absorb the heat from the soldering iron...listen at the speakers searching for the damaged part.

Of course sensitive stages will amplify the AC noise captured by your soldering iron metal chassis....when testing those stages reduce the volume for some seconds...remove the soldering iron and turn the volume up again.

regards,

Carlos

__________________
Dx unbeatable amplifiers; https://www.youtube.com/watch?v=u4tGBiqMnzQ
  Reply With Quote
Old 3rd October 2006, 01:38 PM   #6
Puggie is offline Puggie  United Kingdom
diyAudio Member
 
Join Date: Oct 2004
I have today found out that tapping that amp board causes the speaker to 'crack' loudly so I think it would very well be a dry/broken joint.
  Reply With Quote
Old 3rd October 2006, 02:33 PM   #7
pinkmouse is offline pinkmouse  Europe
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Rotherham, England
popping crackling distortion that clears up after 2 mins Help!!
Blanket resolder, and go over all the traces with a magnifing glass to check for any cracks.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 11th October 2006, 11:13 AM   #8
Puggie is offline Puggie  United Kingdom
diyAudio Member
 
Join Date: Oct 2004
Further to this, I have now solved the loud 'crack pop' noises, by blanket re-soldering the board and changing one Tant capacitor for a back to back pair of electros (was all I had to hand). but now the amp has quite a hiss and crackle which fades in at turn on which clears up after 30sec or so, Someone mentioned the electrolytic caps could be breaking down and healing as a voltage is applied, any ideas?
  Reply With Quote

Reply


popping crackling distortion that clears up after 2 mins Help!!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnosing and fixing amplifier fault (loud crackling and popping) halfgaar Solid State 100 29th January 2012 10:01 PM
Help needed, Primare A10 crackling and popping. Brillegeit Solid State 8 11th December 2011 10:45 PM
Denon pma-1080 cutoff after few mins. Andreash Solid State 5 6th September 2009 07:01 PM
1st ever project finished 2 mins ago - IT PLAYS!! gilbodavid Class D 7 3rd November 2005 09:32 PM


New To Site? Need Help?

All times are GMT. The time now is 01:24 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki