Cyrus 3 Amplifier Component Mistakes? - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st December 2009, 08:34 PM   #11
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi tiefbassuebertr,
Why are you doing this? Why are you digging up every single thread on a Cyrus repair and linking to your incomplete schematic? Did you actually read my responses? If you did, you would understand that your information is not complete and that you've failed to mention the special insulators used. Now that may easily create a time bomb as the outputs overheat.

I'm now annoyed that you indicated that there has been no help given in your post you link to. What the devil do you think I have been doing?

I have helped as much as I can so far. If you doubt this, ask me directly. I feel I have given assistance freely to my limits, and slightly beyond as well.

-Chris
__________________
"Just because you can, doesn't mean you should" my Wife
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cyrus III intergrated amplifier Ashraf Solid State 5 1st December 2009 08:45 PM
First build - Common mistakes Hugo82 Multi-Way 23 17th March 2009 10:16 PM
WTB Cyrus 1 or Cyrus 2 amplifier monstertrucker Swap Meet 0 20th November 2008 02:04 AM
PCB Mistakes/Optimization(?) OmarAvelar Chip Amps 19 10th April 2007 12:01 PM
Cyrus 1 amplifier problem elaar Solid State 2 28th September 2006 11:56 PM


New To Site? Need Help?

All times are GMT. The time now is 06:19 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2