Cyrus 1 amplifier problem - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2006, 08:34 PM   #1
elaar is offline elaar  United Kingdom
diyAudio Member
 
Join Date: Oct 2005
Default Cyrus 1 amplifier problem

Hi,

I have a Cyrus one amplifier that over the years has developed a huge hum, can anyone suggest any possible reasons for this? I was thinking perhaps a ground problem, but what are the best methods of testing for this?

Many thanks,
Alex
  Reply With Quote
Old 2nd September 2006, 10:04 PM   #2
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
be more specific
hum with volume on min?
in both channels equally?
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 28th September 2006, 10:56 PM   #3
diyAudio Member
 
Sonusthree's Avatar
 
Join Date: Dec 2005
Location: Sussex, UK
Given the age of these units I would certainly suspect the Electrolytics.
I'm about to recap my Cyrus Two and PSX. It sounds OK but I'm definitely stretching things expecting them to be good after 11+ years.
Since you did not reply to Zen's post does this mean that you have fixed the problem?

If so I would like to hear how (especially since I own a few Ones and Twos).

If not already fixed then you should definitely provide more details since there are some people around here who have serviced these amps in a professional capacity.
__________________
Martin
+ + =
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cyrus One - problem with new 2SC1775/2SA872 lightning999 Solid State 4 19th February 2011 12:49 PM
Cyrus 3 amp problem scoobdoo Solid State 16 1st December 2009 07:38 PM
Cyrus III+PSX-R problem. Anyone knows? lazarefa Solid State 5 18th May 2009 04:19 AM
WTB Cyrus 1 or Cyrus 2 amplifier monstertrucker Swap Meet 0 20th November 2008 01:04 AM
Cyrus Dad7 problem M5pilot Digital Source 2 15th June 2005 06:19 AM


New To Site? Need Help?

All times are GMT. The time now is 05:35 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2