NAD 3220 PE amplifier problem - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th June 2006, 04:03 PM   #1
diyAudio Member
 
Join Date: Jan 2006
Location: nowhere
Default NAD 3220 PE amplifier problem

Someone gave me a couple of NAD 3220 PE amps for free. He got them somewhere, they were making static noises and he doesn't have time to mess with them.

One amp wasn't putting out sound. The other had sound, but BAD static. I opened both and notice 4 fuses blown where the power cord comes into the amp. I went to Radio Shack and picked up there only pack of matching fuses.

I put the fuses in the amp that had no sound. As soon as I turned it on, the fuses blew. I didn't have more fuses to try in the other amp.

Any ideas as what to check first?

They are supposed to only be 30 WPC, so I don't want to put too much money into them. But I read that they seem more powerful than their rating...so I want to see what I can do.

Thanks.
  Reply With Quote
Old 15th June 2006, 07:28 AM   #2
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
Those things usually blow up big time.

Get the manual from NAD.

Replace all the semis, watch the pin-outs on the BC parts. Add 4.7 ohm base resistors. Add flyback diodes across the outputs. Use MJ15015/16, 03/04, anything other than the 3055/2955 that are in it.
  Reply With Quote
Old 16th June 2006, 05:22 PM   #3
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
IF THE FAULT OR FAULTS IS IN THE POWER AMPS

THE POWER AMP CIRCUIT IS THE SAME AS

THE 3020A 3020i
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clipping control... ACC... NAD 3220 feature, can you explain how this operates? destroyer X Solid State 13 7th May 2008 11:05 AM
sub amplifier problem testarossa2k Subwoofers 4 25th August 2006 06:36 PM
RF Amplifier Problem xitronics Solid State 9 15th April 2006 05:48 PM
Amplifier problem empire Parts 0 4th April 2003 09:43 AM
Amplifier Problem !!! Dj BASS AMP Solid State 14 15th November 2002 01:12 PM


New To Site? Need Help?

All times are GMT. The time now is 09:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2