Precision Power PC2600.2 PPI - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th June 2006, 04:19 AM   #1
diyAudio Member
 
Join Date: Jun 2006
Default Precision Power PC2600.2 PPI

Hey guys!

I'm working on a PPI powerclass series. Model # PC2600.2. Unit stays in over-current protection. The magic power LED never turns green. Tested with several different loads (within PPI specs, 2ohm, 4 ohm, no load). Still no luck. FETS and trans along board edges test fine. Anyone had problems with the thermal interupt preventing initial power up?This amp was said to have never been used. I received it still in the box w/ original wrapping. Any help would greatly be appreciated! Or even recommend a repair center in the Atlanta, GA area.

Thanks,

Mike
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPI amp (power precision) blew out profuse007 Car Audio 125 7th January 2008 10:30 PM
Precision Power PCX2200 skooter Car Audio 7 13th November 2007 11:22 PM
Precision Power PC2600.2 PPI over-current proteciont mikef1897 Car Audio 0 14th June 2006 11:02 AM


New To Site? Need Help?

All times are GMT. The time now is 03:24 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2