Radford Audio Amps - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th May 2006, 07:08 AM   #1
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
Default Radford Audio Amps

Does any one know anything about Radford amps
i have a ZD50 stereo power amplifier its not working
i dont have a manual and Radford no longer trades
The amp needs a good clean and a rebuild

THE FAULT OR FAULTS IS IN THE POWER SUPPLY

THANKS. JIM
  Reply With Quote
Old 28th May 2006, 10:06 AM   #2
latala is offline latala  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: staffordshire
When you say the fault is in the power supply please be more specific. Is there no output is the input faulty
Have you disconnected the power amp modules etc .
From memory there is nothing akward re the the power supply on the radford
regards Trev
  Reply With Quote
Old 29th May 2006, 04:03 PM   #3
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
Hi TREV THANKS FOR THE REPLY

THERES NO OUT PUT. THE POWER TRANSISTOR IS S/C AND
I THINK ITS A 2N3055 BUT I CANT READ THE NUMBERS
ON THE TRANSISTOR
OHM METER CHECKS ON THE TRANSISTORS IN THE POWER AMPS
SHOW NO FAULTS

THANKS. JIM
  Reply With Quote
Old 15th September 2006, 08:28 PM   #4
diyAudio Member
 
Join Date: Sep 2006
Default Radford amp

In the mid-1970's the Radford pre-amp and amp were as close as you could get to Audio Research Corp. in terms of sound and were a little less expensive.
There is a very active Radford group on Yahoo Groups, some speaker discussion, mostly rebuilding the tube units but a good amount of discussion and info on the s.s. amps.

http://tech.groups.yahoo.com/group/radford/

Ken
  Reply With Quote
Old 17th September 2006, 06:54 PM   #5
diyAudio Member
 
bikehorn's Avatar
 
Join Date: Aug 2004
Location: toronto
you don't have to use capitals all the time you know...
  Reply With Quote
Old 24th September 2006, 03:38 PM   #6
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
Default capitals

thanks for your advice friend but what as capitals got to do with



RADFORD amplifier problems
  Reply With Quote
Old 24th September 2006, 05:15 PM   #7
diyAudio Member
 
Join Date: Mar 2002
Location: Canada
Not easy to read when all cap letter.
__________________
Praudio
  Reply With Quote
Old 25th September 2006, 05:31 PM   #8
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
Thanks ken

all the best jim
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radford ZD 50 and ZD 100 schematic anyone ? phase_accurate Solid State 9 20th February 2009 11:16 AM
Radford STA-15 questions patrickamory Tubes / Valves 17 24th November 2007 04:21 PM
Need help with a Radford HD 250 amplifier gaetan8888 Solid State 2 4th July 2007 05:59 PM
SMPS for diy audio amps and multi-channel diy amps (and their power supplies) tlparker Solid State 18 31st August 2006 10:39 AM
Radford STA25 Gram Tubes / Valves 4 15th August 2003 09:32 PM


New To Site? Need Help?

All times are GMT. The time now is 04:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2