Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

need help
need help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd April 2006, 11:40 PM   #1
juan2681 is offline juan2681  United States
diyAudio Member
 
Join Date: Apr 2006
Location: san antonio
Default need help

i tried looking and culdnt find anything on this amp the la490 from lanzar i turn it on and it makes a low pop noise folowed by smoke
Attached Images
File Type: jpg pics.jpg (43.1 KB, 51 views)
  Reply With Quote
Old 2nd April 2006, 11:43 PM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
need help
Hi Juan,
Those are your inverter transistors burnt there.

Test the output transistors for shorts, also the inverters. You will find silicon death. Once you found the reason for the high current draw you can repair the power supply.

-Chris
  Reply With Quote

Reply


need helpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 11:11 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki