Celeste 4070se - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th March 2006, 09:08 PM   #1
diyAudio Member
 
lawbadman's Avatar
 
Join Date: Mar 2003
Location: St. Catherine, Jamaica
Default Celeste 4070se

Hello All,
I just bought a Celeste 4070se but one of the channel is out.
The person who I bought it from said the amp actually stopped working after a storm, so I figure that the input FETs got hit.

Does anyone have the schematic diagram?
Also does anyone know the name of the dual fet transistor at the input stage?



Thanks
Lawrence
__________________
<a href="http://www.danasoft.com"><img src="http://www.danasoft.com/sig/lawbadman.jpg" border="0"></a><div style="font-family:arial,sans-serif;font-size:11px;"><p>Sign by Danasoft - <a href="http://www.danasoft.com">For Backgrounds and Layouts</a></p></div>
  Reply With Quote
Old 10th April 2007, 10:46 PM   #2
diyAudio Member
 
Join Date: Dec 2006
Hey,

I'm having kind of the same same problem, right channel is muddy and a quarter volume of the left.

Have you fixed yours? Did you find a diagram?

Cheers.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 01:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2