diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Amps pilot light doesnt turn in, speaker doesnt work (http://www.diyaudio.com/forums/solid-state/75999-amps-pilot-light-doesnt-turn-speaker-doesnt-work.html)

silentblackhat 16th March 2006 08:29 PM

Amps pilot light doesnt turn in, speaker doesnt work
 
I have a crate 25watt bass guitar amp. I am wondering what is wrong with it or if i can get some direction on what could be wrong so i can try to fix it. Nothing seems to turn on when i press the power button at all. Could it be a fuse? something else? any direction given would be helpful.

anatech 17th March 2006 02:38 PM

Hi silentblackhat,

Unplug the amplifier and carry to your bench.

Test #1 - take your ohmmeter across the AC plug and turn the power switch on. Do you have continuity?

Test #2 (if no) - Measure right across the power transformer primary.

-Chris

BobEllis 17th March 2006 03:08 PM

Gee, that sounds familiar. My son trash picked a Fender Roc-Pro 1000 with the same symptoms. The transformer primary was open. I had a surplus transformer from www.allelectronics.com that was suitable. Total repair cost $11, time 15 minutes and I didn't need to buy the kid an amp :D


All times are GMT. The time now is 08:56 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2