Testing FET transistors - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th March 2006, 08:53 PM   #1
diyAudio Member
 
Join Date: Oct 2005
Default Testing FET transistors

I own a 1988 Fender Princeton Chorus 125 watt amp. It is equpped with FET transistors, but I am not sure what kind of FETs they are. I have been having a problem with the left channel and I suspect that it is the transistor. I have concluded that the jacks the speakers (and my guitars) are not causing the problem. Is there any way I can obtain a common diagnostic on a FET transistor using a DMM?

-Thanks
  Reply With Quote
Old 9th March 2006, 09:20 PM   #2
infinia is offline infinia  United States
diyAudio Member
 
infinia's Avatar
 
Join Date: May 2005
Location: Californication
If you give more discriptions of the problem we could help w/diagnostics.
What makes you think it is a transistor problem?
Have you inspected the inside for obvious stuff like fuses, burned parts, loose connections, cracked pcbs, dirty pots connectors, on & on.
__________________
like four million tons of hydrogen exploding on the sun
like the whisper of the termites building castles in the dust
  Reply With Quote
Old 9th March 2006, 09:26 PM   #3
diyAudio Member
 
Join Date: Oct 2005
Default Testing FET Transistors

I have checked for other common problems withing the amplifier circuit. The amp runs fine with the left channel disconnected but when you hook up both speakers, the whole amp seems to clam up. I will get mixed disturbances from the amp upon turn on such as loud crackling that is not affected by the volume level. I also recieve a muffled buzzing sound from both speakers that causes their voice coils to fully extend as if the speaker was being pushed out with your hands. I am not sure if these are common characteristics of a transistor problem, but all other parts in the amp seem to have their integrity. This is a fairly vague problem and I have not pinpointed any exact cause. I do know how to test all basic components of a circuit. Are their any other crucial parts that I could test that could also be responsible for making this noise?
  Reply With Quote
Old 9th March 2006, 09:29 PM   #4
diyAudio Member
 
Join Date: Oct 2005
BTW, the entire stem of the presence knob is cracked. Im not sure if that could mean anything. The problem occurs on both clean and overdrive settings.
  Reply With Quote
Old 9th March 2006, 11:02 PM   #5
lineup is offline lineup  Sweden
diyAudio Member
 
lineup's Avatar
 
Join Date: Dec 2005
Location: the north
What MOSFETS are those?

Name and/or number?
What is the text on those BIG transistors?
Those ones onto the heatsink.
__________________
lineup
  Reply With Quote
Old 10th March 2006, 12:47 AM   #6
diyAudio Member
 
Join Date: Oct 2005
NEC Japan
uPC1188H
L8938J

in that order on the transistor
  Reply With Quote
Old 10th March 2006, 01:02 AM   #7
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi sound_prodigy,
That's an entire chip amp. They normally die with a crater in the center, or at less an evil looking crack.

This is the data sheet for your chip.
Download it and have a look.

-Chris
  Reply With Quote
Old 10th March 2006, 01:37 AM   #8
diyAudio Member
 
Join Date: Oct 2005
Thanks a lot for sending me the list.
Basically i dont have many options now because there are a million things that could be wrong with this amp.
I feel guilty taking it to somebody but thats what ill probably end up doing.
The amps been with me through thick and thin, i dont want to give up on it now.
  Reply With Quote
Old 10th March 2006, 01:42 AM   #9
diyAudio Member
 
Tube_Dude's Avatar
 
Join Date: Mar 2002
Location: Aveiro-Portugal
Default Re: Testing FET Transistors

Quote:
Originally posted by sound_prodigy
I also recieve a muffled buzzing sound from both speakers that causes their voice coils to fully extend as if the speaker was being pushed out with your hands.

I think that you have DC at the output of the amp and this can be lethal for the speaker's voice coil...
I think the amp is faulty ,don't connect the speakers , unless the problem is solved...
__________________
Jorge
  Reply With Quote
Old 10th March 2006, 03:35 AM   #10
infinia is offline infinia  United States
diyAudio Member
 
infinia's Avatar
 
Join Date: May 2005
Location: Californication
Just from the info you gave, it sounds like it may be a leaky capacitor.
I wouldnt plug a speaker on it unless you were willing to lose it.
What i would do is take an old cheap speaker in series w a 200 ohm 5Watts resistor and troubleshoot it some more, try different channels and settings to localize the problem a little more. The resistor will protect the amp and speaker from putting out high power. This will drop the volume 20/30db at all settings.
Or just take it to the shop if you are not too handy with fixing gear.
__________________
like four million tons of hydrogen exploding on the sun
like the whisper of the termites building castles in the dust
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
whats the besy way of testing Sanken LEXAM SAPM01 transistors??. joeyuk Solid State 13 8th July 2009 12:16 AM
Testing transistors with DMM or VOM Apogee Solid State 3 25th July 2003 01:45 AM
amp testing Kilowatt Solid State 10 10th May 2002 09:10 PM


New To Site? Need Help?

All times are GMT. The time now is 09:56 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2