Problems with NAD 3020e - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th January 2006, 11:17 AM   #1
pho_boi is offline pho_boi  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
Default Problems with NAD 3020e

Hello Friends,

My dad owns a NAD 3020e stereo amplifier for years now, but lately I've noticed something wrong about it.

It seems that the right channel is distorting and producing a clipping sort of sound. I've swapped speakers around and also used some headphones through the headphone out and the problem still occurs in the right channel.

Anyone know what seems to be wrong from my vague description
  Reply With Quote
Old 1st February 2006, 08:57 AM   #2
pho_boi is offline pho_boi  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
can anyone help me out
  Reply With Quote
Old 1st February 2006, 09:00 AM   #3
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Firstly, try cleaning all the pots and switches with contact cleaner. If that doesn't work, search here, there are several threads dealing with troubleshooting this amp.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 1st February 2006, 09:02 AM   #4
Banned
 
Join Date: Jan 2005
I had this fault too on a amp, tho it was intermittent. I could be a loose solder joint or a broken copper trace.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of Nad 3020e questions soupdragon Solid State 4 14th February 2010 02:02 AM
nad 3020e bull041161 Solid State 18 29th March 2009 12:38 AM
P3A Problems please help!! TedPolzin Solid State 8 7th February 2003 10:54 PM
KEF Q35 problems Kollega Multi-Way 1 27th January 2003 10:01 AM


New To Site? Need Help?

All times are GMT. The time now is 12:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2