Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st January 2006, 02:26 AM   #1
MGR is offline MGR
diyAudio Member
 
Join Date: Oct 2002
Location: Philippines
Default S - Paul P32 amplifier

Hi to everyone
Has anyone by chance repaired an amplifier by the name S-Paul P32?I got this amplifier with both channels damaged,some of the resistors and parts are beyond recognition.It would be a great help if anyone has schematics for this unit.Attached are pictures of the unit.


Regards MGR
Attached Images
File Type: jpg s4010038.jpg (39.1 KB, 654 views)
  Reply With Quote
Old 18th August 2006, 12:10 PM   #2
AJT is offline AJT  Philippines
diyAudio Moderator
 
AJT's Avatar
 
Join Date: May 2003
Location: Palatiw, Pasig City
Hi MGR,

any luck with the amp yet?
  Reply With Quote
Old 19th August 2006, 01:35 AM   #3
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
Looks like we need to reverse engineer it or get a schematic.
  Reply With Quote
Old 16th September 2006, 07:00 AM   #4
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
hello,

I hope this could help. This is a P22 Spaul Amplifier. This came to my shop today for service. Maybe you could get some clues. Observing your pics, the burned components are a rectifier diode and two resistors.
Attached Images
File Type: jpg spaul p22.jpg (27.3 KB, 299 views)
  Reply With Quote
Old 16th September 2006, 07:02 AM   #5
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
another pic
Attached Images
File Type: jpg spaul p22 a.jpg (27.6 KB, 260 views)
  Reply With Quote
Old 16th September 2006, 07:04 AM   #6
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
top view of the board
Attached Images
File Type: jpg spaul p22 b.jpg (28.5 KB, 275 views)
  Reply With Quote
Old 16th September 2006, 07:27 AM   #7
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
another top view

here are the arrangement of the components 1/2W 100 ohm resistor,
1/4W 4.7K ohms, 1N4007 with the cathode pointing at the rear of the amp then the busted 47uF/160V elec.cap Hope this helps

Best Regards,
Audiomachines
Attached Images
File Type: jpg spaul p22 c.jpg (27.2 KB, 236 views)
  Reply With Quote
Old 16th September 2006, 02:51 PM   #8
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
Looks like you got a damaged driver stage.Wondering is the output stage damage too???
  Reply With Quote
Old 16th September 2006, 10:54 PM   #9
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
no damage on the driver stage or the ouput, the turn on delay/dc protection ckt. is the problem, It takes 45 seconds for the relay to activate, While the "normal" is around 5 to 10 seconds.
  Reply With Quote
Old 18th September 2006, 05:11 AM   #10
MGR is offline MGR
diyAudio Member
 
Join Date: Oct 2002
Location: Philippines
Thanks audiomachines but I have sincescrapped the original circuit , I have reverse engineered it and I found out the topology used was Class AB with the output in series connection to handle the +- 100V supply.I have replaced it with a Class H design.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paul Harvey is gone... moray james Everything Else 1 2nd March 2009 01:10 AM
Paul Hales has left QSC! Zero Cool Multi-Way 3 18th October 2008 01:12 PM
Question for CarlosFM & jean-paul georgehifi Solid State 3 28th August 2006 10:43 AM
Paul McCartney's latest CD John Hope Music 2 31st October 2005 06:36 AM


New To Site? Need Help?

All times are GMT. The time now is 01:39 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2