Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th June 2013, 05:30 PM   #501
diyAudio Member
 
Ben Hanke's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Send a message via MSN to Ben Hanke Send a message via Skype™ to Ben Hanke
I didn't double them up personally.
__________________
Modified Marantz CD63KI -> Modified PM66KI -> B&W 805S
  Reply With Quote
Old 18th September 2013, 11:07 PM   #502
diyAudio Member
 
Join Date: Sep 2012
Hello again,

I finally got my old amp up and running again and it's been treating me well for the last couple of months, but I just moved house recently and it's begun to play up again!

Basically, if i turn the amp above a certain volume, the speaker protection relay clicks into action and cuts all the sound, then will come back on within a couple of seconds. It sometimes clicks on and off repeatedly, but turning down the volume generally helps.

From looking around online, most people seem to be pointing towards something as simple as needing to clean the relay connections, but I was just wondering if anyone has had this issue before and if they managed to fix it with ease.

Thanks,

David
  Reply With Quote
Old 19th September 2013, 04:43 AM   #503
diyAudio Member
 
Join Date: Dec 2012
Location: Buenos Aires
Have you checked out for DC voltage at the amplifier output related to volume pot position? May be the speaker protection circuit is triggering for a reason.
In that case you'll have to trace the dc component origin being amplified.

As a side note, the relay coil is operated by the protection circuit, which is independent of the relay contacts condition.
__________________
Pablo
  Reply With Quote
Old 12th December 2013, 09:04 AM   #504
diyAudio Member
 
curiosogti's Avatar
 
Join Date: Dec 2013
Location: spain
Hello

New Kid in Town

this is my working progress
Attached Images
File Type: jpg CURIOSO AMP.JPG (136.9 KB, 72 views)
  Reply With Quote
Old 16th December 2013, 08:02 AM   #505
diyAudio Member
 
curiosogti's Avatar
 
Join Date: Dec 2013
Location: spain
Some ideas:

My other amp can donate the big capacitors so I can end with 12000x4

Is better for the bass ?
with the second transformer it doesn´t matter ??

Is this too much cap??

The s4vb20 bridge can supply 2.6 amp continuos without heatshink and 4 amp if I put one heatskink ( peak surge forward current, non-repetitive 1 cycle = 80amp)

Well I have got a metal big 35 amp bridge. I can put it near the two Transformer, in the chasis. I can put the two new capacitor (12000+12000) near the bridge, and left the original caps near the transistor...

what do you think ?
worth it ??



PD: sorry for my english

Last edited by curiosogti; 16th December 2013 at 08:07 AM.
  Reply With Quote
Old 23rd January 2014, 06:28 AM   #506
diyAudio Member
 
Ben Hanke's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Send a message via MSN to Ben Hanke Send a message via Skype™ to Ben Hanke
Hi curiosogti,

Your English is fine. Brent had 22,000uF Silmics in his amp, so doubling the caps should be OK.

Nice job with your placement of the second transformer. It looks good.

Ben
__________________
Modified Marantz CD63KI -> Modified PM66KI -> B&W 805S
  Reply With Quote
Old 25th January 2014, 04:26 PM   #507
diyAudio Member
 
Join Date: Sep 2009
Location: Stavanger (NORWAY)
To answer the question about capacitance ... from the beginning of the 3D

Quote:
Originally Posted by Fidelity Audio View Post
I have done quite a few mods to this amp now so I thought I should post a pic.
The most noticable mod is the rather small res caps. lol
The bass is very good from these caps and no loss of treble etc.
Click the image to open in full size.
Click the image to open in full size.
Maybe this is too much. But 2 nice 47000 uF ...
Regards,
gino
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz PM66 se problems, information wanted alan_w Solid State 8 6th August 2012 05:13 PM
Quad II Mods/Tweeks slurb.net Tubes / Valves 62 16th June 2012 12:32 AM
wanted marantz pm66 amp paul.42 Swap Meet 0 6th April 2009 08:09 PM
Tweeks on tubes - bring out the demagnetiserss ashok Tubes / Valves 36 3rd August 2004 05:34 PM
expert tweeks for PA? Pbassred Multi-Way 4 7th December 2003 08:57 PM


New To Site? Need Help?

All times are GMT. The time now is 07:53 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2