Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2005, 02:11 PM   #1
diyAudio Member
 
Join Date: Nov 2005
Default Adcom GFA-555II problem

Hello all,
I have a 555II with a ground problem. The amp is overheating,when I measured the bias voltage it was extremly high on both channels. I tried to lower it but had no success. Then I measured the ground at the RCAs and nothing. I solder a temporary cable to the RCAs ring and grounded it and the problem was fixed but this is obviously not the right way to do it. I like to know if anybody around here has had this problem and if so what's causing the problem. I do have the service manual.
Thanks to all.
  Reply With Quote
Old 10th November 2005, 01:02 AM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi oscarav098,
Check R104 / R154. They are 100 ohms from the signal common to ground. They may go open if a differential voltage appears between the inputs and chassis ground.

Replace with the same parts. Carbon film is original, you can use metal film if you want.

-Chris
  Reply With Quote
Old 10th November 2005, 03:47 PM   #3
diyAudio Member
 
Join Date: Nov 2005
Default Thanks

I'll check them today and replace if they're bad.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom GFA-555II badfireguy Solid State 8 1st March 2012 05:02 AM
Adcom GFA-555II the apostate Solid State 32 2nd September 2011 08:41 AM
Adcom GFA-555II with DC Offset sjdemark Solid State 19 28th February 2009 01:33 PM
Problem with Adcom GFP-555II claiborne Solid State 2 22nd April 2008 05:50 PM
Adcom GFA-555II PS for sale oscarav098 Swap Meet 2 3rd December 2005 02:03 PM


New To Site? Need Help?

All times are GMT. The time now is 08:51 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2