HELP with a rega brio! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th September 2005, 10:47 AM   #1
jercab is offline jercab  Sweden
diyAudio Member
 
Join Date: Sep 2005
Default HELP with a rega brio!

Hello every one. I have a problem with my rega brio. One chanel on PHONO in are busted and i need to disasamble the amplefire. I can remove the back side but then i am stuck... How do i do the rest from there???


Thanks!
  Reply With Quote
Old 5th October 2005, 02:43 AM   #2
diyAudio Member
 
Join Date: Jan 2005
Location: Østfold
If my memory is right, Rega Brio has some screws going through the feet.

Regards,
Peter
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rega Brio (one channel dead) cosinus Solid State 20 15th August 2014 07:50 PM
Rega R5 inside culture Multi-Way 3 14th November 2007 01:41 PM
rega p2 hum mpmarino Analogue Source 7 20th August 2006 03:38 AM
rega P3 motor- DIY woodturner-fran Analogue Source 5 28th June 2006 11:02 AM
Simple DIY VTA for Rega ericpeters Analogue Source 1 7th July 2004 03:22 PM


New To Site? Need Help?

All times are GMT. The time now is 10:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2