first pcb attempt - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th September 2005, 12:47 PM   #1
m0nty is offline m0nty  Italy
diyAudio Member
 
Join Date: Feb 2005
Location: near Venice
Send a message via MSN to m0nty
Default first pcb attempt

i have done my first pcb this morning:
1) printed the reversed image on paper
2) photocopied it on a transparency film (0.4 €, i had 2 films done)
3) ironed it on a cheap copper board for 3-4 mins (0.3 € for a 16cm x 10cm)
4) about 50 min into ferric chloride (6€ for 1 lt)

i'm not a master, but i think the result is pretty good
here it is

bye
Attached Images
File Type: jpg img_0260.jpg (58.0 KB, 280 views)
  Reply With Quote
Old 24th September 2005, 01:47 PM   #2
Giaime is offline Giaime  Italy
diyAudio Member
 
Giaime's Avatar
 
Join Date: Oct 2004
Send a message via MSN to Giaime
Good work for a first try!!!

I cannot see why it should be so imprecise in the traces... if the original image is straight and perfect, what causes the traces to be so "whacky"?
  Reply With Quote
Old 24th September 2005, 02:59 PM   #3
diyAudio Member
 
Join Date: Sep 2001
Location: Salt Lake City
Well done! Thats very similar to how my first boards looked. The more you make the better you will get at it.

One suggestion you may want to try... your etch time was pretty long and you probably let the board go under the solution face up. If you float the board on top of warmed up solution it will etch completely in about 15 min and this completely eliminates undercutting or etch through of very small traces. What happens this way is that the heavy copper thats being etched away will fall to the bottom of the tray of solution because of its weight and fresh ferric chloride will always be in contact with the copper. Works for all but very large and heavy boards. I remember reading this tip in Popular Electronics way back in the late 60's and have done it this way ever since.
  Reply With Quote
Old 25th September 2005, 05:07 AM   #4
diyAudio Member
 
Join Date: Jun 2004
Location: HKSAR
Hi m0nty,

It's good to try. I am not trying to discourage you but there are things that you can do better.

The two "fat" traces running vertically on the lower right side of the board looks a bit sloppy. Did you do a touch up for the trace with a marker? You can put "scotch" on both sdie of a trace before touching-up with markers, that makes them more sharp and thin.

The one running horizontally underneath the ground trace on the upper left side is getting too close to the ground (or are they part of it?) You have to give more clearence there. When touching up with marker, do twice to get a better cover of the traces

As Mark suggest, use warm etchant at about 70-65 degree C. What I useally do is I drill one of the mechanical holes (3mm dia.)first, pass a wire tie that can just go thru from the copper side. When you put the board face down into the etchant, one side of the board will be slightly elevated by the "knot" of the tie so that the copper side will not get in close contact with the bottom of your trough, giving way for etchant to do their work with the copper. While you are waiting for the etching, you can slight paddle you board by pulling the tie. ie. a human agitator. It saves me about 5 mins doing this.

Hope this can help.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My ESL attempt SM7UYJ Planars & Exotics 144 4th March 2010 02:22 PM
First attempt j beede Planars & Exotics 21 27th December 2008 05:31 AM
First DIY amp attempt! RTF671 Instruments and Amps 8 8th June 2008 03:22 AM
My first attempt mikee55 Chip Amps 4 26th March 2006 12:16 AM


New To Site? Need Help?

All times are GMT. The time now is 11:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2