rockford 800a2 fried channel help . - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd July 2005, 07:42 AM   #1
diyAudio Member
 
Join Date: Jul 2005
Location: Freakville, fl
Default rockford 800a2 fried channel help .

OK... i have a rockford 800a2 one chanel quit working. i opened it up and took my B&K transistor testor and tested that 10 transistors are bad. five IRF640 and five IRF 9640. I replaced them as well as the 10 gate resistors. i was really sure this was all that needed replaced.
well i hooked it up to my aston power supply. all 10 of the transistors i replaced fried within 30 seconds. they got super hot super fast. I Get a voltage reading of around 45+ volts form this speaker output. the working channel I get .3 volts. I am lost now. does anyone have any insight on this.
  Reply With Quote
Old 22nd July 2005, 08:02 AM   #2
clem_o is offline clem_o  Philippines
diyAudio Member
 
Join Date: Jun 2005
Location: Manila
Could be several things, but try first looking at the bias circuit, see if anything's open!

After replacing the output MOSFETs again, ensure you put an incandescent lamp IN SERIES with the AC power input of the amplifier first. A good way of doing this is to remove the mains fuse of the ampli and connecting the incandescent bulb across. A 50W or 100W bulb should do, and will make a very nice "unbreakable" fuse that will save your new output transistors from destruction if there is still something amiss in the amp...

Cheers
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford fosgate 800a2 fongman Car Audio 40 9th September 2014 11:18 AM
New member 800a2 ? Twoloudnproud Car Audio 11 6th March 2009 12:32 AM
Possibly Fried Alpine MRV-F352 5 channel Car Amplifier lickwid Car Audio 19 2nd March 2009 04:34 AM
rockford 800a2 fried channel help . ethridgeruby Car Audio 3 27th July 2005 06:09 PM


New To Site? Need Help?

All times are GMT. The time now is 08:20 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2