FT15K mosfet power amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th June 2005, 12:03 AM   #1
diyAudio Member
 
Flavio88's Avatar
 
Join Date: May 2005
Location: Roma
Question FT15K mosfet power amp

Sorry, i'm italian and my english is terrible
Futura Elettronica FT15K mosfet amp.
Some opinions about this power amplifier?
For me this is a very good amp.:
  Reply With Quote
Old 11th June 2005, 02:48 AM   #2
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
Any pictures????
  Reply With Quote
Old 11th June 2005, 08:33 AM   #3
diyAudio Member
 
Flavio88's Avatar
 
Join Date: May 2005
Location: Roma
I attached the original pdf.
Sorry is in italian
Attached Files
File Type: pdf 7100-ft15k.pdf (50.8 KB, 536 views)
  Reply With Quote
Old 11th June 2005, 08:49 AM   #4
diyAudio Member
 
Flavio88's Avatar
 
Join Date: May 2005
Location: Roma
Some questions:
Can you recommend me some transistors to replace the MPSAs? They are too much noisy.

I have replaced the input electrolytic cap with a mkt cap,there is others upgrades that i can do?

Here is the MPSA92 datasheet
  Reply With Quote
Old 12th June 2005, 02:02 AM   #5
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
A quite traditional circuitry.Nothing special but reliable.

I did use the 2SA872 for the input pairs,2SB647/2SD667 for the driver stage,and the obsolute 2SK135/2SJ50 for the output stage.U can try them if u want
  Reply With Quote
Old 12th June 2005, 04:54 PM   #6
diyAudio Member
 
Flavio88's Avatar
 
Join Date: May 2005
Location: Roma
Thanks for your advise. I'll do my best.

I need a special help... At first in one of the two channels the zobel network resistor (R17)went up in smoke, after changing it everything went OK, but now happens the same problem to the other channel, in your opinion it could be a problem due to the substitution of the input capacitors? Or due to an anomalous high frequency oscillation? If yes, what can I do to compensate this oscillation?

Tanks...
  Reply With Quote
Old 13th June 2005, 02:33 AM   #7
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
I havent encounter such problem,so really cant make any correct statement on this one.

To me,possibly the quality of the component itself or maybe like what u have saidscillation.

If u really worry about the oscillation,try to increase the value of C2 to 470pF,will limit the input bandwidth to around 150kHz,seems enough to me for audio application
  Reply With Quote
Old 13th June 2005, 10:05 AM   #8
ilimzn is offline ilimzn  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: Zagreb
Quote:
Originally posted by Flavio88
Thanks for your advise. I'll do my best.

I need a special help... At first in one of the two channels the zobel network resistor (R17)went up in smoke, after changing it everything went OK, but now happens the same problem to the other channel, in your opinion it could be a problem due to the substitution of the input capacitors? Or due to an anomalous high frequency oscillation? If yes, what can I do to compensate this oscillation?

Tanks...
This would almost certainly be caused by HF oscilation...
  Reply With Quote
Old 13th June 2005, 01:22 PM   #9
diyAudio Member
 
Flavio88's Avatar
 
Join Date: May 2005
Location: Roma
Thanks to everybody but I have resolved the problem:
It was only a grounding error, I didn't have connected the chassis to ground.

Leolabs, can i use also the 2SA872/2SC1775 instead of the
MPSA92/MPSA42 for the entire circuit?

The collector current rating of 2sa/2sc is more less of the mpsas,
does it change something?


sorry for the english
Thanks...
  Reply With Quote
Old 14th June 2005, 02:30 AM   #10
Leolabs is offline Leolabs  Malaysia
diyAudio Member
 
Leolabs's Avatar
 
Join Date: Dec 2004
Location: Bukit Mertajam
Send a message via MSN to Leolabs
The 2SA/2SC pair u suggested is normally for input stage,if they are used at driver stage,i dont think they will drive the MOSFETs.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ESP P101 vs FT15K what is the best? Flavio88 Solid State 39 22nd April 2013 11:15 AM
Power MOSFET chlim74 Car Audio 17 20th May 2012 02:49 PM
Ft15k mosfet paralleling Flavio88 Solid State 10 2nd January 2007 05:17 PM
MOSFET power amp help pollypocket Solid State 19 7th December 2006 06:01 PM
Hi-power mosfet Stefano Pass Labs 1 20th October 2003 09:03 PM


New To Site? Need Help?

All times are GMT. The time now is 02:42 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2