diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   FT15K mosfet power amp (http://www.diyaudio.com/forums/solid-state/58893-ft15k-mosfet-power-amp.html)

Flavio88 11th June 2005 12:03 AM

FT15K mosfet power amp
 
Sorry, i'm italian and my english is terrible
Futura Elettronica FT15K mosfet amp.
Some opinions about this power amplifier?
For me this is a very good amp.:

Leolabs 11th June 2005 02:48 AM

Any pictures????

Flavio88 11th June 2005 08:33 AM

2 Attachment(s)
I attached the original pdf.
Sorry is in italian :D

Flavio88 11th June 2005 08:49 AM

Some questions:
Can you recommend me some transistors to replace the MPSAs? They are too much noisy.

I have replaced the input electrolytic cap with a mkt cap,there is others upgrades that i can do?

Here is the MPSA92 datasheet

Leolabs 12th June 2005 02:02 AM

A quite traditional circuitry.Nothing special but reliable.

I did use the 2SA872 for the input pairs,2SB647/2SD667 for the driver stage,and the obsolute 2SK135/2SJ50 for the output stage.U can try them if u want:)

Flavio88 12th June 2005 04:54 PM

Thanks for your advise. I'll do my best.

I need a special help... At first in one of the two channels the zobel network resistor (R17)went up in smoke, after changing it everything went OK, but now happens the same problem to the other channel, in your opinion it could be a problem due to the substitution of the input capacitors? Or due to an anomalous high frequency oscillation? If yes, what can I do to compensate this oscillation?

Tanks...

Leolabs 13th June 2005 02:33 AM

I havent encounter such problem,so really cant make any correct statement on this one.

To me,possibly the quality of the component itself or maybe like what u have said:oscillation.

If u really worry about the oscillation,try to increase the value of C2 to 470pF,will limit the input bandwidth to around 150kHz,seems enough to me for audio application:)

ilimzn 13th June 2005 10:05 AM

Quote:

Originally posted by Flavio88
Thanks for your advise. I'll do my best.

I need a special help... At first in one of the two channels the zobel network resistor (R17)went up in smoke, after changing it everything went OK, but now happens the same problem to the other channel, in your opinion it could be a problem due to the substitution of the input capacitors? Or due to an anomalous high frequency oscillation? If yes, what can I do to compensate this oscillation?

Tanks...

This would almost certainly be caused by HF oscilation...

Flavio88 13th June 2005 01:22 PM

Thanks to everybody but I have resolved the problem:
It was only a grounding error, I didn't have connected the chassis to ground.:D :D :D

Leolabs, can i use also the 2SA872/2SC1775 instead of the
MPSA92/MPSA42 for the entire circuit?

The collector current rating of 2sa/2sc is more less of the mpsas,
does it change something?:confused:


sorry for the english
Thanks...

Leolabs 14th June 2005 02:30 AM

The 2SA/2SC pair u suggested is normally for input stage,if they are used at driver stage,i dont think they will drive the MOSFETs. :whazzat:


All times are GMT. The time now is 03:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2