Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Car amp repair: Overheated my a/d/s PH15...
Car amp repair: Overheated my a/d/s PH15...
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st May 2005, 04:57 AM   #1
Tremelune is offline Tremelune  United States
diyAudio Member
 
Join Date: May 2005
Location: New York City
Default Car amp repair: Overheated my a/d/s PH15...

I've got a 6ch a/d/s amp sitting on my shelf that I just haven't been able to get rid of...It was in my car, working great, when it starting cutting out (it has temp sensor that will cause itself to shut down if it gets too hot). Well, it would cut out, then come back, then cut out...Eventually, after weeks, it just cut out and never came back.

I'm wondering if anyone has any experience with a/d/s amps...It's not so expensive an amp that I can spend hundreds repairing it...I opened it up and didn't notice anything "fried." I have the repair circuit diagram, but honestly it's just beyond my understanding. I'm decent with a soldering iron, but my test equipment consists of a 300W ATX power supply and a RadioShack voltometer...

It just seems like it would be replacing the temp sensor or something...I dunno, I don't think any of the channels blew out...

Failing my handiwork...Someone mentioned K&B Audio for repair. Anyone ever heard of them? I also found some electronics repair FAQ. If anyone knows a good place in Mahatten...lemme know...
  Reply With Quote

Reply


Car amp repair: Overheated my a/d/s PH15...Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LM3875 overheated h@kan Chip Amps 10 30th June 2008 09:47 PM
FS: a/d/s Ph15 amplifier - 50% working - $50 owdi Swap Meet 4 28th September 2007 04:24 PM
Overheated Midiland Amplifier/Subwoofer mobiustripper Subwoofers 2 14th March 2005 08:14 PM


New To Site? Need Help?

All times are GMT. The time now is 06:47 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki