Problem on Rowland model2 need help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd May 2005, 06:34 PM   #1
Chalitr is offline Chalitr  Thailand
diyAudio Member
 
Join Date: Mar 2005
Location: Samutprakarn
Default Problem on Rowland model2 need help

Have somebody here familiar with these amp. I have the problem happen while the amp switch back to stand by mode during normal listening. Preliminary measure found DC voltage at right channel output, which cause DC servo shut it down. However, I just unplug the eletrical cable cord and start run the amp again on the next day and problem has gone. I can play the amp around 6-7 hrs without any problem. However, the problem coming back again on evening with the same right channel. Can sombody here probide me any suggestion on how to check this thing? In the PCB board, I found the 3 adjusting knob (1. offset 2. Biasand 3. Temp). I suspected that the amp is drift out and need to adjust them back to target. Can anyone here give me some suggestion on how to adjust these knob?

Appecaite your suggestion.

Chalit R.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
diy Jeff Rowland Concerto PC-1 mbl Class D 2 15th January 2013 02:42 AM
Noise problem in Jeff Rowland Consonance Pengvim Solid State 0 25th September 2008 01:05 AM
ROWLAND Research D40 Amp happy_guy Solid State 5 15th September 2007 06:43 PM
Jeff Rowland Consonance display problem DirkD Solid State 1 19th July 2005 01:01 PM
Jeff Rowland ben goh Analogue Source 0 14th May 2005 06:04 AM


New To Site? Need Help?

All times are GMT. The time now is 09:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2