Electrocompaniet ECI-4??? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st May 2005, 07:33 PM   #1
diyAudio Member
 
Join Date: Dec 2004
Location: Denmark
Default Electrocompaniet ECI-4???

Hello.

I am searching for a servicemanual or schematic for the integrated amplifier off Electrocompaniet ECI-4.

Can any off you help me with that please?

I can send you some great schematic in trade.

Best regards

Kim
  Reply With Quote
Old 21st May 2005, 09:42 PM   #2
diyAudio Member
 
Join Date: Dec 2004
Location: Denmark
Hello all.

If you got Electrocompaniet ECI-4 schematic and want to trade, then I scan one off these schematics for you:

Classe cam350 monoblock
Electrocompaniet AW100,AW180 AW250 and electrocompaniet preamplifier.
Sony
Nad
Denon
Marants pm14

Best regards
  Reply With Quote
Old 17th February 2010, 10:27 PM   #3
AudioBS is offline AudioBS  United States
diyAudio Member
 
Join Date: Feb 2010
Default Electrocompaniet ECI-4 Schematic

Hello there, I am searching for the same thing you were nearly 5 years ago, did you finally find it? If so, any chance you can share it with me? Thanks very much in advance!
  Reply With Quote
Old 17th February 2010, 11:11 PM   #4
wahab is offline wahab  Algeria
diyAudio Member
 
Join Date: Nov 2009
Location: algeria/france
electrocompaniet schematics are like the loch ness monster..
everybody talks about it, but no one seems to have really saw it..
the only schematic i managed to get seems right for the toplology
but wrong for some components values..
anyway, good luck..
  Reply With Quote
Old 17th February 2010, 11:36 PM   #5
AudioBS is offline AudioBS  United States
diyAudio Member
 
Join Date: Feb 2010
So the only way to fix anything really is to send it to authorized service center, since Electrocompaniet is not in the US?
  Reply With Quote
Old 18th February 2010, 08:55 AM   #6
wahab is offline wahab  Algeria
diyAudio Member
 
Join Date: Nov 2009
Location: algeria/france
their schematic seems to be generic through the different amps they made...
so if you can get one genuine schematic, you can iterate according to your model parameters, power, supply voltage and so on..
basically, it s a triple serial differential...
  Reply With Quote
Old 18th February 2010, 09:10 AM   #7
Account disabled at member's request
 
Join Date: May 2006
I have several original schematics but not ECI 4 model
  Reply With Quote
Old 18th February 2010, 10:22 AM   #8
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
Quote:
Originally Posted by wahab View Post
electrocompaniet schematics are like the loch ness monster..
everybody talks about it, but no one seems to have really saw it..
the only schematic i managed to get seems right for the toplology
but wrong for some components values..
anyway, good luck..
Yes, I note the same. Please read more about this thread:
Electrocompaniet Ampliwire 100 (AW 100 AW100) different Versions
I think, the same problem there is also here by the ECI4.

Therefore I am not a very great admirer of this devices.
At least all older models needs redesign in some aeras, both regarded the electronic components so as the circuit and layout design.

Even if someone here post a circuit diagram, one should make his own schematic and accurately compare with the original printed version.
Any detected differences should be resolved.
And deficiencies in circuit design should also be respected.
The reasons for darkened PCB aeras (hot spots through thermal overheating) should be also resolved (by newer versions of AW100 often to observe).

Last edited by tiefbassuebertr; 18th February 2010 at 10:27 AM.
  Reply With Quote
Old 22nd February 2010, 05:38 AM   #9
AudioBS is offline AudioBS  United States
diyAudio Member
 
Join Date: Feb 2010
Thanks guys for the responses! I need the schematic to fix one of the blown channel of the ECI-4, everywhere else is working fine, just need the values to get replacement parts. If I can't get it, I guess I will just drop it on Agon for sale as is for a few hundred bucks. Unit in mint shape cosmetically, what a shame...
  Reply With Quote
Old 23rd February 2010, 04:35 AM   #10
ben goh is offline ben goh  Singapore
diyAudio Member
 
Join Date: Jun 2001
Location: nil
Send a message via AIM to ben goh Send a message via Yahoo to ben goh
Hi AudioBS,

What is the problem with the faulty channel? Which values are you checking?

Can you post a pic of the area? Maybe I can help a bit.

Thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from an Electrocompaniet Fan PrimeCase Introductions 10 25th September 2012 01:17 PM
DAC electrocompaniet ecd tweak? ffarges Digital Source 1 17th December 2008 11:28 AM
Electrocompaniet Help Andypairo Solid State 66 9th July 2008 10:13 AM
Electrocompaniet AW 250 AMP. hogue Solid State 1 1st March 2004 05:48 AM


New To Site? Need Help?

All times are GMT. The time now is 09:01 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2