Adcom Channel Damage Help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th May 2005, 02:53 AM   #1
diyAudio Member
 
Join Date: Sep 2002
Location: Long Island, NY
Default Adcom Channel Damage Help

I was thinking of buying an Adcom amp. The seller says he accidentially shorted the positive & negative speaker leads from one channel. That channel doesn't work now.

I'd appreciate a general idea of what could have gotten blown. He says he hasn't opened the case. Does Adcom have internal fuses to protect against what happened or is it more likely something more serious is damaged.

I've built a few sets of speakers but have never tinkered inside an amp.

Any guidance and ideas would be very appreciated.
__________________
Probably a silly question, but ........
  Reply With Quote
Old 9th May 2005, 03:37 AM   #2
Account Disabled
 
Join Date: Aug 2004
Location: Earth
Not at all a silly question. You could lift the lid as you possibly have one good channel to compare and contrast. However you should be able to find a schematic out there or someone will post one to determine what protections are in place to protect against such treatment.
  Reply With Quote
Old 1st June 2005, 05:41 AM   #3
diyAudio Member
 
Join Date: Jun 2005
Location: southern California
Ralph-- I have had 15 years of great listening with an Adcom GFA-555, Adcom GTP 400 pre-amp, Apogee Centaur Minor speakers, and Swiss Symo LS-5 SX speaker cabling. Although I generally tread very, very carefully around my equipment, I finally accidentally stepped on the speaker cable to the right channel about 3 weeks ago. The connectors simply pulled out of the right Apogee speaker; however, I have had no right channel at all since this occurred. I tested both speakers (both are fine), switched out interconnects and speaker cable, and alas, the right channel is still completely dead. This circumstance sounds somewhat similar to the story you received from the seller you described in your post.

I have almost no skill at all as regards any thoughts of carrying out a repair on my own, and I must admit that time constraints are even worse than my lack of skill..

I would be curious to know if it is worth attempting to locate the talent needed for the repair work or if it might be just as worthwhile replacing the amplifier.

Any thoughts?

Thanks.
  Reply With Quote
Old 1st June 2005, 06:00 AM   #4
Account Disabled
 
Join Date: Aug 2004
Location: Earth
Perhaps a fuse has blown, designed just to deal with such an occasion!

Now wouldn't you feel like a goose if you .....

Greg
  Reply With Quote
Old 1st June 2005, 05:46 PM   #5
jasonva is offline jasonva  United States
diyAudio Member
 
jasonva's Avatar
 
Join Date: Mar 2005
Location: VA
Unhappy Adcom Trouble?

Yes, there are fuses inside that Adcom.

Simply unplug it from the wall, find the correct size Allen driver (2.5MM I think) and remove the top.

You will see 2 fuses per side in the corners nearest the top and front of the unit. remove these and go looking for replacements at any auto parts, hardware, electronics store.

replace and be happy.

I purchased a 545II for $200 and put a .15 cent fuse in it and now I can't tell the difference between it and my $500 original.
  Reply With Quote
Old 2nd June 2005, 02:19 AM   #6
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi agingaudionut,
Either send the unit to Adcom or call them so you can bring it to the nearest warranty depot. A good tech job is priceless, a bad one is more than a complete waste. Generally speaking, a shop that does lots of TV's is not a good choice.

A good tech will have this unit sounding at least as good as when it left the factory. And it will keep playing for years unless you kill it.

-Chris
  Reply With Quote
Old 2nd June 2005, 04:33 PM   #7
Heiney9 is offline Heiney9  United States
diyAudio Member
 
Join Date: Apr 2005
Location: MidWest
Default Adcom Service

Don't mean to derail this thread too much. But has anyone heard of the health of Adcom these days. I know the owner of a big marketing firm in my area has stopped distributing Adcom because of quality control issue's. He thinks they maybe going out of business soon. I guess it was costing him more to distribute Adcom because of the replacement and repair of defective new product. I may be way off base here, about them going belly-up. I've always held Adcom in high regard and would be sad to see them leave the market. I'm sure repair of old as well as new would go on as usual.

I have a GFA-545 that's 20 years old and sounds as good today as it did when I bought it! My advice; get it repaired and you will be very happy!

Just wondering if anyone else has heard this recently about Adcom. Sorry if this is off topic too much.

Brock
  Reply With Quote
Old 2nd June 2005, 09:29 PM   #8
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi Brock,
News to me, but .... who knows these days.

-Chris
  Reply With Quote
Old 2nd June 2005, 09:37 PM   #9
diyAudio Member
 
Join Date: Jan 2002
Location: Puget Sound
Default Re: Adcom Trouble?

Quote:
Originally posted by jasonva
Yes, there are fuses inside that Adcom.

Simply unplug it from the wall, find the correct size Allen driver (2.5MM I think) and remove the top.

You will see 2 fuses per side in the corners nearest the top and front of the unit. remove these and go looking for replacements at any auto parts, hardware, electronics store.

replace and be happy.

I purchased a 545II for $200 and put a .15 cent fuse in it and now I can't tell the difference between it and my $500 original.
I've shorted my Adcom GFA-545II twice now. Pulled the top off and replaced the fuse and it sounds just fine.

If the fuse looks unblown, pull it and measure it with a DMM. One time it happend, I did a visual and both fuses looked fine. I ended up pulling them both out and measuring them. Turned out one was in fact blown. I had to use a magnifying glass to see the break in the wire.
  Reply With Quote
Old 2nd June 2005, 10:30 PM   #10
K-amps is offline K-amps  United States
diyAudio Member
 
K-amps's Avatar
 
Join Date: Nov 2003
Location: Indiana
If you have shorted the speaker wires together, best case scenario is it needs a fuse replaced, most likely scenario is a couple of blown output devices which are not too hard to replace (if you know what you are doing)... worst case scenario.... well I will leave it at that.

In lower rail (545 etc) designs ( typically below +/-70 vdc) chances are fair that only a fuse is gone, in higher rail designs (like the 555) more likely that the outputs are shorted... exceptions notwithstanding.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom GFA-555 MKii blown channel checklist? l.a.rossmann Solid State 0 10th May 2009 07:39 AM
adcom GFA2535 4/3 channel amp johnmark Swap Meet 0 15th December 2008 10:32 PM
Adcom 555 II channel failure computeruser Solid State 89 14th May 2006 06:33 AM
One channel board for Adcom GFA-7000 pablo170 Parts 1 23rd March 2006 01:10 AM
Adcom GFA 7500 channel problem G-Rock Solid State 2 19th May 2005 02:09 AM


New To Site? Need Help?

All times are GMT. The time now is 06:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2