Adcom GFA535..Bad Transformer? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th May 2005, 09:12 PM   #1
diyAudio Member
 
EchoWars's Avatar
 
Join Date: Dec 2002
Location: Left of the Dial
Default Adcom GFA535..Bad Transformer?

I have a buddy who lives many miles from me who is having problems with a pair of Adcom GFA535 amplifiers after an electrical storm. He took them to a local (to him) repair place and was told that the primaries on both are opened. I'm sceptical, since the favorite buzzword of a clueless or lazy tech is 'bad transformer'.

Is there anything in the primary of a 535 that might make it appear that the transformer is bad (soft-start, NTC thermistor...)? If it appears that the transformers are indeed bad, are the voltages from the transformer close to a standard that might make them easy to replace with an aftermarker transformer?

Thanks guys!
  Reply With Quote
Old 5th May 2005, 10:01 PM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi EchoWars,
I'd be surprised to see an electrical storm take out the transformer. The shop may have killed them by shorting the fuse and turning them on. I'd be taking them back in a hurry. Measure the primary to see if they are open (thermal fuse gone). You may be able to replace those (takes some skill and luck).
May just be a shorted rectfier or output. Some repair guys aren't to swift. (I'm a repair guy, I've seen so much destruction at the hands of other techs). TIM - technician induced malfunction.

-Chris
  Reply With Quote
Old 5th May 2005, 10:32 PM   #3
diyAudio Member
 
EchoWars's Avatar
 
Join Date: Dec 2002
Location: Left of the Dial
Fair enough. You are suggesting that the transformer has a thermal fuse in there somewhere?

You wouldn't happen to know the transformer secondary voltages are?
  Reply With Quote
Old 6th May 2005, 12:01 AM   #4
diyAudio Member
 
Join Date: Mar 2005
Location: California
I was going to say don't be so quick to judge an unknown repair shop, but then I thought of some my stories (I've been out of the biz for 8 years now - 'the good ol'days'). In general I'd have to say for the amount of knowledge and skills needed to be really good it is almost as badly paid as teaching (my new profession).

But back to the topic: I can imagine lightning taking out a transformer, of course I would expect many other electrical things in the house to be also damaged.
Thermal fuses in xformers - I know why they are there but why not make them easily replaceable? Seemed such waste to have to throw out a large lump for the sake of a cheap fuse. I did repair some, and a few had extra terminals which you bridge and check if everything else was OK - of course with lawyers and all I was not about to bypass the thermal fuse.
If you can replace it careful with that soldering iron ...
  Reply With Quote
Old 6th May 2005, 01:24 AM   #5
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
What kind of transformer is in side ? Round or squar ? Can you get a pic of inside of it. ?
  Reply With Quote
Old 6th May 2005, 01:44 AM   #6
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi EchoWars,
Yes there is a fuse in there, can't remember what the secondaries are. I did get some thermal fuses from Nakamichi years ago ... or was it Adcom. Can't remember. I do recall changing them.
My point was, confirm the fault first. Go from there. Any time I've seen lightning take someting out, that something was usually a semiconductor or few (and tubes - wow). Power transformers normally survive. They are tough critters.
-Chris
  Reply With Quote
Old 6th May 2005, 01:59 AM   #7
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Quote:
Originally posted by anatech
Hi EchoWars,
Yes there is a fuse in there, can't remember what the secondaries are. I did get some thermal fuses from Nakamichi years ago ... or was it Adcom. Can't remember. I do recall changing them.
My point was, confirm the fault first. Go from there. Any time I've seen lightning take someting out, that something was usually a semiconductor or few (and tubes - wow). Power transformers normally survive. They are tough critters.
-Chris

I agree the reason i asked about the kind of tranny was to help you locate the fuse and get it apart. Trannys are really strong devices. I saw a carver trany die due to max load max power running and the speakers shorted out and well the amp was a paper weight : O )
  Reply With Quote
Old 6th May 2005, 03:10 AM   #8
woodman is offline woodman  United States
diyAudio Member
 
Join Date: Dec 2003
Location: New Jersey
It's been a long time since I've worked on a 535, but I do remember that a few Adcom units had MOVs, (though they were usually preamps or sources). If the 535 has them, then they would be small bright blue epoxy capacitors, most likely on the PS board.

I've also had to replace a couple of 535 xfmrs, bur never both at the same time.

FWIW - Even though the 535 is rated at 60WPC, it really goes to 80WPC PS sag included!

Good luck!
__________________
-JamesW-
www.thevoorhees.com - on hold temporarily.
  Reply With Quote
Old 6th May 2005, 03:26 PM   #9
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
E&I type dual 70VCT at 250VA (total), 52V no load.
  Reply With Quote
Old 6th May 2005, 08:51 PM   #10
diyAudio Member
 
EchoWars's Avatar
 
Join Date: Dec 2002
Location: Left of the Dial
djk...thank you!!

No toroids on the 535? And I assume that it uses a single transformer and power supply to power both channels? No, the unit isn't here, and I don't think I've ever seen the inside of a 535.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom transformer for Leach Amp? WithTarragon Solid State 8 25th March 2009 06:51 PM
Larger transformer for Adcom GFA555ii WithTarragon Solid State 9 13th February 2008 02:35 PM
Which Driver To match NHT SuperOne & ADCOM GFA535? yehuda44 Subwoofers 3 24th January 2008 07:34 AM
Adcom GFA535 bias adj. ostie01 Solid State 0 22nd January 2006 12:49 AM
Adcom GFA-585 went bad - calling Adcom experts hangguy Solid State 14 24th December 2004 08:09 PM


New To Site? Need Help?

All times are GMT. The time now is 09:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2