diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Finished my solid state plate amp (http://www.diyaudio.com/forums/solid-state/56706-finished-my-solid-state-plate-amp.html)

Bensen 5th May 2005 03:19 PM

Finished my solid state plate amp
 
2 Attachment(s)
Hello,


2 years ago, I started building this amp. With many disappointments, I finaly can present this to all of you DIY'ers.

Components:
650VA amplimo toroid with soft-start circuit for the toroid and mains conditioning.
2 x 25000F on elco's, BC components
2 x Crescendo ME amps with 2 output devices/rail
1 x balanced active transmitter to bridge the two amps.
http://sound.westhost.com/project87.htm

1x sub-bass processor
http://www.geocities.com/f4ier/xover.htm

The amp measures 500 by 310mm, and weights about 8kg.
The processor still has to be mounted to the small alluminium plate. But everything else is finished and tested.
On the scope, I've seen 76Vpp before clipping on a 8ohm woofer.

Now I have to build the enclosure for the Peerless XLS12 woofer and PR.

Offcourse I would like to thank all the people who helped me with this project.
URSV for the output devices
Wuffwaff and Rudy for information
And all off you guys who inspired me.

Enjoy the pictures.

Bensen 5th May 2005 03:22 PM

2 Attachment(s)
Some other pics

Bensen 5th May 2005 03:23 PM

2 Attachment(s)
3e

Bensen 5th May 2005 03:24 PM

2 Attachment(s)
4e


All times are GMT. The time now is 08:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2