Please Help - amp pop, shut down - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th April 2005, 10:45 PM   #1
bonz is offline bonz  United States
diyAudio Member
 
Join Date: Dec 2004
Location: Ohio, United States
Unhappy Please Help - amp pop, shut down

Hello,
I am having trouble with my subwoofer. I am posting this thread here because I think the problem is in my amp. Sorry if I am posting in the wrong area.
A brief description of my dilemna, after my sub has been on a few minutes, it makes a popping noise and shuts down (I believe into a protection mode). It will not come back on for about 15-30 minutes. Then, I get to go thru the whole frustrating experience again.
Unfortunately, I am not very experienced with troubleshooting amplifiers. I only know enough about electronics to get myself into trouble. I also am quite poor at the current time and cannot afford to have it professionally serviced. This leaves me trying to fix this thing myself.
Would someone be willing to suggest where I should begin to troubleshoot? Any help would be greatly appreciated...
I have visually checked the components and solder joints on the amp plate under a magnifier. All appear to be in good shape. I have checked the resistor and cap that are bridged across the active woofer and they also checked fine.
Please, please, please help me...
Thanks,
Bonz
  Reply With Quote
Old 30th April 2005, 11:08 PM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi Bonz,
Do you have a digital multimeter? If so, is it any good?

The popping noise sounds like DC offset or protection cutting vas current. Tap the board with the amp just turned on, use something non-metallic. Does the heatsink (the "plate") get hot?

-Chris
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz SR5200 immediate shut-off kwadrofonik Solid State 3 30th July 2013 07:21 PM
NAD 5325 CD Tray won't stay shut dman535 Digital Source 2 24th February 2008 08:33 PM
PE Bash 500 Amps shut down problems? crippledchicken Subwoofers 2 6th August 2007 12:29 PM
x-over makes my amp get hot and shut down SimontY Solid State 10 16th April 2004 04:00 PM


New To Site? Need Help?

All times are GMT. The time now is 09:22 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2