ilimzn-Question for you??? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th April 2005, 04:32 AM   #1
zox2003 is offline zox2003  United States
diyAudio Member
 
Join Date: Nov 2004
Location: usa
Default ilimzn-Question for you???

I forgot to ask you two more things about your amplifier you posted for me:

1. In text you attached with schematic you stated that amp can give me 60W of clean power.LAter on you were talking obout 120-140w.So,what is power of that amp with +/-42V one pair of IRFP240/9140(i just received 9140 today) on 4 ohms?

2.You were also talking about Q7,Q8,Q6 possible temperature problem.Can i replace Q6,Q7,Q8,Q10 with MJE340/350?Will amplifier get worse after that or will stay the same?

Thanks for your help.

P.S

How many have you build?Do they work in first shot?
Eade li iz prve bez nekih vecih problema.
Hvala na velikoj pomoci...
  Reply With Quote
Old 9th April 2005, 10:38 PM   #2
ilimzn is offline ilimzn  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: Zagreb
Default Re: ilimzn-Question for you???

Quote:
Originally posted by zox2003
I forgot to ask you two more things about your amplifier you posted for me:

1. In text you attached with schematic you stated that amp can give me 60W of clean power.LAter on you were talking obout 120-140w.So,what is power of that amp with +/-42V one pair of IRFP240/9140(i just received 9140 today) on 4 ohms?
On it's own, assuming perfectly stiff 42V rails (meaning, no drop in voltage under 10A peak load), it will do 120-140WPC into 4 ohms.
It was originally designed to preoduce 60W into 8 ohms but be capable of driving difficult and low impedance loads, hence the capability to produce a lot more power into 4 ohms, BUT for this you need good power supplies.
Keep in mind that if you use an unregulated power supply, rails should never go over 50V (meaning under high AC condition (245V) and no load.
The reason why I said 60W clean power into 8 ohms, is that the 40-42V rails were originally form an unregulated supply, so rail sag was included in the calculation.

Quote:
2.You were also talking about Q7,Q8,Q6 possible temperature problem.Can i replace Q6,Q7,Q8,Q10 with MJE340/350?Will amplifier get worse after that or will stay the same?
The reason for this is Q6, 7, 8 being small transistors, intended for 0.5W maximum heat disipation under ideal conditions (and they never are!), dissipating about 0.2W. They do get quite hot and will work fine under normal conditions, but if ventilation is not good or there are other hot things around, their lifetime will be shortened. A small heatsink would help (that's what i used), or a different transistor.
You could use MJE340/350 but the performance will degrade somewhat as the original transistors were chosen for high gain and Ft. BD139/140 would be better but then the power rails should never go over 40V, which is a limitation in your case.

Quote:
How many have you build? Do they work in first shot?
Eade li iz prve bez nekih vecih problema.
Hvala na velikoj pomoci...
20 so far, in form of four 5 channel amps. All worked perfectly first time without any problems at all.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
do i REALLY need a crossover?? and an amp question. and an ohm question legendaryfrog Multi-Way 4 29th October 2006 01:39 AM
Question for all mighty ILIMZN and others... bogdan_borko Solid State 36 10th February 2006 11:45 AM
newbie with input tran. question and wiring question imo Solid State 0 18th January 2006 10:10 PM
PS question - tformer question actually breguetphile Chip Amps 2 30th May 2003 01:29 PM
old speaker question, bullet midrange question & link to speaker project wallijonn Multi-Way 10 5th November 2002 06:03 AM


New To Site? Need Help?

All times are GMT. The time now is 12:47 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2