Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th March 2005, 08:29 AM   #1
diyAudio Member
 
Join Date: Sep 2004
Location: London
Smile QSC Amp Problem

Sorry, (Correction): QSC RMX 2450
  Reply With Quote
Old 27th March 2005, 02:06 PM   #2
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Question Hi

what is the type of problem do you have with Pat Quilter's amplifier.
  Reply With Quote
Old 27th March 2005, 06:18 PM   #3
diyAudio Member
 
Bill Fitzpatrick's Avatar
 
Join Date: Jun 2001
Location: Eugene, OR
We don't need that information. I can diagnose the problem with out knowing the symptoms.

It'll take a while though . . .
  Reply With Quote
Old 29th March 2005, 05:30 AM   #4
diyAudio Member
 
Join Date: Sep 2004
Location: London
Smile QSC Problem Update!!!

Sorry folks,
It appeared it didnít display the original message: Anyway the problem is with a QSC RMX 2450 amp basically the amp is operating normally and without problem, then it will suddenly blow the fuse in the AC plug regardless of whether there is anything going thru the amp. There seems to be no pattern to it as it will go for several weeks without problem then it will pop several fuses one after another for no apparent reason... Iíve isolated it and ran it on an AC circuit that I believe nothing else is drawing current from. Plus we also have another amp of the same type in the building that is unaffected... (Eliminating buliding AC problems)... Strange one huh!! Anyway do you guys know of any test I can do to determine the nature of the problem as I donít want to send it to the repair shop unless itís actually broken...

Thanks for your help

Darren
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mtx amp problem [[help!!]] fuzzypinkhat45 Car Audio 3 8th July 2008 05:34 AM
CDM 2/29 Problem Ė HELP! Bassivus Digital Source 29 23rd December 2007 10:00 AM
FRD/ZMA Problem Twisted85 Multi-Way 5 4th December 2006 01:19 PM
p3a problem MaXiZ Solid State 17 16th July 2005 07:14 AM


New To Site? Need Help?

All times are GMT. The time now is 12:24 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2