Technics new class-a amp (runs cold ?) - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th March 2005, 10:45 PM   #1
Rixsta is offline Rixsta  United Kingdom
diyAudio Member
 
Join Date: Feb 2004
Location: Barrow-In-Furness, Cumbria
Send a message via Skype™ to Rixsta
Default Technics new class-a amp (runs cold ?)

I just got a old technics amplifier from my local dump "su-v3"

one channel is not working and to my surprise the heatsink or the output transistors dont even get warm
but the other channel of the amp is working.

Does anyone have any idea why this amp would run cold
maybee both the right and left channel need to work for it to bias into class-a properly

It's got good low distortion specs and good enoth to power a tweeter or mid speaker

any help will be apriciated
__________________
www.Rixsta.co.uk Free music recorded by me/DIY pics Currently Selling, amps=Zen V4, Zen-lightenment‎, Jean Hiraga 20w, F5, F5T
  Reply With Quote
Old 17th March 2005, 02:48 AM   #2
BrianL is offline BrianL  United States
diyAudio Member
 
Join Date: Mar 2002
Location: USA
This is probably not a "true" class A amp. Most likely
it has some sort of sliding bias arrangement so that none
of the output transistors ever turns off. But dissipation-wise
it's more like a class AB
__________________
bel
  Reply With Quote
Old 17th March 2005, 09:56 PM   #3
Rixsta is offline Rixsta  United Kingdom
diyAudio Member
 
Join Date: Feb 2004
Location: Barrow-In-Furness, Cumbria
Send a message via Skype™ to Rixsta
You are right ..Thanxs brian - L

The amp also says synchro-bias on the front
i went searching the net and found not much info

A definition can be found here

http://www.geocities.com/technicshifi/Bias.html

I think ill repair it and power a pair of scanspeak tweeter's
when i can afford it
__________________
www.Rixsta.co.uk Free music recorded by me/DIY pics Currently Selling, amps=Zen V4, Zen-lightenment‎, Jean Hiraga 20w, F5, F5T
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
80s Amps: Technics New Class A, SU-V2X arki Chip Amps 7 31st October 2013 01:21 AM
Forte Model 1a Class A amp runs ice cold rsquare Pass Labs 17 30th September 2011 02:35 PM
Technics Class A Biasing atiq19 Solid State 46 15th January 2009 09:31 AM
Technics Class-AA / Sandman Bridge richie00boy Solid State 13 28th June 2004 08:39 AM


New To Site? Need Help?

All times are GMT. The time now is 12:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2