JLH problems - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd November 2004, 01:14 AM   #11
diyAudio Member
 
chris ma's Avatar
 
Join Date: Sep 2001
Location: Pickering, Canada
Default Size matter

Hi,

If you are aiming for 2A the heat sink should not be less than 2 pound in weight per output transistor in order to keep the heat sink below 60 degree C at room temperature of 25C without using a fan.. do over kill here and good luck with your project...

Regards,
Chris
  Reply With Quote
Old 2nd November 2004, 06:17 PM   #12
diyAudio Member
 
Join Date: Jan 2004
Location: Cortez Colo.
Thanks for the info.
If I loose a rail I will end up with 22v at the speaker?
Thanks again.
Serosmaness
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GFA-565 problems ben62670 Solid State 5 14th August 2008 06:36 AM
HK AVR 335 Problems utjay2008 Solid State 0 21st October 2007 02:26 AM
Nak dvd-10s problems MadMutt Digital Source 8 26th March 2007 10:06 AM
Sub Amp Problems Thanks! crippledchicken Solid State 2 10th January 2007 06:17 PM
RFI problems laz Solid State 3 21st February 2004 07:06 AM


New To Site? Need Help?

All times are GMT. The time now is 08:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2