Power amp marantz PM-80SE no output - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th October 2004, 01:34 PM   #1
diyAudio Member
 
Join Date: Sep 2004
Location: Goa
Default Power amp marantz PM-80SE no output

Hi!

Is any one out there from diy can help me. I m struggling with my marantz PM80se
No output amps in protect mode.
In pre-amp module STK-3102-IV, output relay control TA7317P, output driven by C3182N and A1265N.
Let me explain what step I have taken.
I checked all supply voltages and transistors seem look like every thing is o.k.
Replaced TA7317P, since STK-3102-IV is obsolete and not available
Replaced with STK-3102-III I want to make it 100%sure this IC will work or not?
Tried some substitute in local market STK350-030, 3122,3152 they are too not available. Is there any modification? How can I resolve my amp problem?

Francisco
  Reply With Quote
Old 6th October 2004, 02:31 PM   #2
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
Fransisco,
Near the relay you will find a few 1W resistors. Check them.
Here's a datasheet for the 3102.
Look with a scope if the output transistors are driven, pin 5/6 and 10/11 of the 3102.
If the 3102 is broken, you might have a problem...

Good luck

/Hugo
  Reply With Quote
Old 6th October 2004, 06:44 PM   #3
diyAudio Member
 
djmiddelkoop's Avatar
 
Join Date: Feb 2003
Location: Noord-Holland
Francisco,

I have repaired several PM80.
Some months ago a replaced a STK-3102-IV which I ordered somewhere on the Internet, don't know where anymore.
Try a Google search, thats what i did.

Usually the STK is bad, replacement with a III also works, tried it once.

What kills them here is the dissipation due to increased supply voltages, which happens cause the line voltage here is slowly increasing.

So make shure the supply voltages are ok, otherwise use an other tab of the transformer primary or increase the resistors in value that go to the supply pins of the STK.

Dick.
__________________
“Information is not knowledge.Knowledge is not wisdom.
Wisdom is not truth.Truth is not beauty.Beauty is not love.Love is not music.Music is THE BEST.”
  Reply With Quote
Old 9th October 2004, 10:44 AM   #4
jitter is offline jitter  Netherlands
diyAudio Member
 
jitter's Avatar
 
Join Date: Aug 2004
Location: Eindhoven, The Netherlands
Francisco, if you perform a search on the topic "PM80SE" you will find my posts regarding the repair of my PM80SE. It didn't have the same symptoms you described, but in the posts you will find a source where I got a brand new STK3102-IV from.
  Reply With Quote
Old 12th November 2004, 03:48 PM   #5
hdlbq is offline hdlbq  France
diyAudio Member
 
Join Date: Nov 2004
Location: gif sur yvette
Default problem with a Marantz PM-80

Hello,

I have some output problem (no output, since no "click" after warm-up) on a PM-80 Marantz.

After carefull look, I have found two relays driving the power to speakers, and a very hot and burned resitor near one of them. I have unsoldered it.

Many strange things: the color circles say: 119 ohms, but the measure reports 289 ohms. And the voltage measured at its ends is about 40 volts (too much, even for a 1W model) !!

Lastly, I can "force" the power to goes out by gently pushing the contacts of the relay, but i4m looking for a better way to re-use my amp.

thanks for any suggestion
Best regards
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz 9 output power switch Tubesin Tubes / Valves 3 20th December 2008 02:08 AM
Need Help: Aura AUV-80SE fossil2k Solid State 4 11th October 2007 10:18 AM
problem with Marantz amp PM-80SE Crecencio Solid State 1 5th June 2005 05:09 PM
PM-80SE schematics. Francisco Swap Meet 0 7th October 2004 10:57 AM
I2S digital output in Marantz CD4000 and four TDA1541A with balance analog output iklari14 Digital Source 30 18th July 2003 12:57 PM


New To Site? Need Help?

All times are GMT. The time now is 08:14 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2